Cursor jumping around in IEX.

Hi there,

I’ve just started learning Elixir. I have noticed an annoying problem when using IEX - the cursor jumps around when typing parenthesis. Please see this screen capture:

I found if I use the environment variable TERM=dumb this problem doesn’t happen.

Is there any way to disable this annoying behaviour? I am using the Terminal app on OSX.


1 Like

Hello and welcome,

It does not jump around… it briefly indicates the opening parenthesis when closing one.

It’s clear if You type (“long long params”), You will see it highlights briefly the start, then goes back to normal position.

Thanks @kokolegorille. Is there any way to disable this behavior? I’m used to other REPL environments and while I can see it being useful to others, it keeps distracting and frustrating me.