Database metrics is not instrumented in NewRelic using elixir_agent

I want to configure newrelic for my database/ecto but database report section in newrelic has no data.
I tried going through the documentation but I can’t find the solution how to configure it for the same.

My config.exs:

config :app, MyApp.Web.Endpoint,
  ...the config lines
  instrumenters: [NewRelic.Phoenix.Instrumenter]

My repo.ex

defmodule MyApp.Repo do
  use Ecto.Repo,
    otp_app: :app,
    adapter: Ecto.Adapters.Postgres

Can anyone please help out here, I am stuck for days now.

I haven’t tried New Relic with Ecto but you might have to setup a transaction to report. Things don’t magically work like they do in Ruby for NewRelic from my experience

Sorry, Can you please help me out here how do I configure for the same as I am beginner on elixir.

I am myself new to elixir and haven’t worked with Ecto yet but if you add
NewRelic.start_transaction("Task", "TaskName")
to the code block you are looking to have metrics about can check what it captures in new relic dashboard.

Yes, all other metrics are being sent as required however only the database metrics is not available.

There are ppl on forum from new relic they would probably be your best bet