Debugging with IntelliJ fails

I’ve been trying to debug just a simple Phoenix application with IntelliJ, but it doesn’t work.

Firstly, I created a “hello” Phoenix application with the following command.

mix phx.new hello --no-ecto --no-brunch

Then, I created a IntelliJ project by importing the source code and set up the Run/Debug configurations. However, when I try to run the project, it shows the following messages.

/Users/tsuyoshi.yamaguchi/erlang/20.3/bin/erl -noshell -s elixir start_cli -extra /Users/tsuyoshi.yamaguchi/.kiex/elixirs/elixir-1.6.5/bin/mix phx.server
{“init terminating in do_boot”,{undef,[{elixir,start_cli,[],[]},{init,start_em,1,[]},{init,do_boot,3,[]}]}}
init terminating in do_boot ({undef,[{elixir,start_cli,[],[]},{init,start_em,1,[]},{init,do_boot,3,[]}]})

Crash dump is being written to: erl_crash.dump…done

I read this post and checked my configurations, but it seems fine.

Is there any idea what is the problem?

IIRC, I never got debugging working in IntelliJ, but it did work in VS Code.

If that is the complete command line, then it looks like it is using the fallback erl invocation when your Elixir SDK and it’s Erlang SDK are not setup for the project. Make sure those are setup using the Import Project From External Model (Mix) in the README. If they are setup correctly you’ll see a bunch of -pa ...ebin flags after erl adding the paths to Erlang and Elixir before starting elixir start_cli

Thank you! I made sure VS Code provides the debug capability and it works :slight_smile:

1 Like

Thank you for your advice!
I made sure that I set up the project as README mentioned, but it doesn’t work. If I figure out what’s wrong later, I’ll let you know.

Check that your SDKs are setup. They should have been created during the import if missing:

  1. File > Project Structure
  2. Click Platform Settings > SDKs
  3. Verify you have an Elixir SDK
  4. Click the Elixir SDK
  5. Verify you have an Internal Erlang SDK on the Elixir SDK
  6. Verify the Elixir SDK has both Elixir and Erlang ebin directories like .../elixir/ebin and erlang/lib/kernel-5.4.1/ebin
  7. Click Project Settings > Project
  8. Verify Project SDK is the Elixir SDK?
    9 .Click Project Settings > Modules
  9. Click each Module and verify they also have the Elixir SDK set.
1 Like

Thank you for your detailed explanation. I made sure each settings.

Verify you have an Elixir SDK
Verify you have an Internal Erlang SDK on the Elixir SDK

Verify the Elixir SDK has both Elixir and Erlang ebin directories like …/elixir/ebin and erlang/lib/kernel-5.4.1/ebin

I checked the following directories exist:

/Users/tsuyoshi.yamaguchi/.kiex/elixirs/elixir-1.6.5/lib/elixir/lib/elixir/ebin
~/erlang/20.3/lib/kernel-5.4.3/ebin

Verify Project SDK is the Elixir SDK?

Click each Module and verify they also have the Elixir SDK set.

Run/Debug configuration is set:

I think all settings seem to be set correctly, but it still shows the same error.
BTW, I’m using Kiex as an Elixir version management tool. Do you think it could possibly be the cause of the problem?

Sorry, I didn’t mean to imply check they exist on-disk. I mean that they should appear in your Classpath tab. Here’s what it looks like locally for me, using homebrew:

I’m going to guess that something is missing with the kiex and/or kerl support. You should be able to work-around this issue by manually adding the ebin directories using the + button the Classpath tab.

1 Like

You’ve hit the nail!

I checked Classpath, and it turned out ebin paths was not set at all. After setting ebin paths manually, the debug mode worked out.

I looked around some source code of the IntelliJ plugin, and apparently the path to the ebin directories are different from the path expected when using Kiex, so I guess that would be the cause.

I really appreciate your advice anyway. Thank you!

1 Like

This just helped me out. Thanks for posting your solution!

1 Like