Dializer (via Dialyxir) warning about “but this value is unmatched” from `forward` command for Absinthe (GraphQL) route. How to address?

Hi all,

I asked a question on stackoverflow (https://stackoverflow.com/questions/59486093/dializer-via-dialyxir-warning-about-but-this-value-is-unmatched-from-forwar). Can anyone provide any insights on the error and how to resolve? Please answer here or on Stackoverflow, wherever you want. I’ll update Stack if you answer here.

Thank you so much.

I think the easiest is to use an ignore file as described in dialyxirs README.

Can’t get into more details as I’m on mobile and doing multitab is tedious…

1 Like

What version of Absinthe and Phoenix are you using, it’s strange, that dialyzer does not like the forward functions return value, because you’re not matching on it, nor assigning it to anywhere.

Maybe in that if in your routes could have :ok as a last line (after forward) and everything works? :grimacing:

Using latest of all the things :thinking:

      {:phoenix, "~> 1.4.10"},
      {:phoenix_pubsub, "~> 1.1"},
      {:phoenix_ecto, "~> 4.0"},
      {:ecto_sql, "~> 3.1"},


      {:dialyxir, "~> 1.0.0-rc.7", only: [:dev], runtime: false},
      {:absinthe, "~> 1.4"},
      {:absinthe_plug, "~> 1.4"}

I downgraded to 0.5 but still got the same error (just formatted differently)

I’m not an Elixir expert so I may be misunderstanding. I added an :ok on the next line :man_shrugging: Same error though. Perhaps I’m implementing it incorrectly. Mind showing me the code you’re suggesting?

I have rather similar setup in the app I’m working on these days, and no errors. Unfortunately I cannot share code. Can you share your code, or make a reproducible sample, and upload it to github or similar site, so we can download it and dissect it locally?

1 Like

Hey @woohaaha, are you still struggling with this?

If you can share a repo where we can reproduce the problem, awesome.

Without being able to play with the code and try things, sometimes is just hard to figure out where is the issue. That’s true for code in general, but specially true for dialyzer :stuck_out_tongue: