benonymus
Hey there,
When I upload a file that is too big, in dev I am getting the phoenix error that looks like this:
Plug.Parsers.RequestTooLargeError at POST/topics/4gvJMZkdbBpN0e65/post_attachment
the request is too large. If you are willing to process larger requests, please give a :length to Plug.Parsers
and has a status of: 413 Request Entity Too Large
but when I deploy the app this error gets swallowed it seems, and just an empty 500 is returned.
in the AWS logs I can see the 413.
How to handle this error to have the same error the same way on both environments?
Trending in Questions
I having some trouble figuring out if I have set myself too strict of standards for my production server. Currently I can handle 75% of r...
New
Hello,
I know there is an approach for handling lists that allows for optimized traversal, but I can’t recall the specific method (somet...
New
Documentation
While reading the Scoped Routes section, I noticed that the documentation currently refers to a problem without explainin...
New
Hi everyone,
I am toying with the idea of building a “match maker” for giving personal help to people that wants to start coding.
I sta...
New
So my question is quite simple and i have found no conclusive answer on forum, google or AI.
Should we use :erlang.float for Integer to ...
New
I recently noticed that Elixir’s Logger defaults its primary log level to :debug when no :logger, :level application configuration is pre...
New
I’m new to elixir and just tried to install the elixirLS extension for VScode(ium) and it is throwing some errors that I would like help ...
New
Other Trending Topics
Edit: 2026 May 15 - This post is archived.
Mob is alive!!
Main docs: mob v0.7.11 — Documentation
A bit of explanation for the slightly c...
New
Hey, I’m Jesse and I’m the main contributor behind Dexter, a full-featured, lightning-fast Elixir LSP optimized for large codebases. It s...
New
I am happy to introduce the very α version of the new programming language compiled to BEAM.
Welcome Cure.
It has literally three kille...
New
Hobbes is a low-level distributed database for the Elixir programming language.
Hobbes provides a simple, safe, and scalable storage lay...
New
Hi everyone!
The first release candidate for the Expert language server project is now available!
We’ve published a press release detai...
New
A little off-topic, but I feel like people here have a good head on their shoulders.
I used to be quite good at making software. Was luc...
New
Categories:
Sub Categories:
Forums
Popular Tags
- #ecto
- #liveview
- #troubleshooting
- #learning-elixir
- #library
- #deployment
- #erlang
- #testing
- #genserver
- #mix
- #absinthe
- #remote-other
- #otp
- #plug
- #how-to-question
- #macros
- #postgres
- #elixirconf
- #channels
- #exunit
- #discussion
- #code-sync
- #podcasts
- #javascript
- #onsite
- #dialyzer
- #docker
- #authentication
- #umbrella
- #full-time-contract
- #podcasts-by-brainlid
- #ecto-query
- #ai
- #elixirconf-us
- #blog-post
- #elixir-ls
- #phoenix_html
- #iex
- #graphql
- #genstage
- #websockets
- #supervisor
- #advent-of-code
- #distillery
- #processes
- #elixirconf-eu
- #api
- #forms
- #metaprogramming
- #hex










Showing Posts 1 to 10- Show Best Posts
- Show All (oldest first)
- Show All (newest first)
jola
First step is probably to try running it in “prod mode” locally, see if you can reproduce the issue. But after that it depends on what your production environment looks like. You’re on AWS? So you have an ELB in front of your app? Are you also running a reverse proxy like nginx?
benonymus
Thanks for the answer, I am able to reproduce it locally, I am not convinced that the aws stuff is related.
Here it is:
the same thing happens btw if i don’t change the lenght value in Plug.Parsers
benonymus
so it seems lit wants to give back an html error and not a json
jola
So it only happens when you run with
MIX_ENV=prod? I’d compare thedevandprodconfigs, maybe take a look atrender_errorsanddebug_errors, off the top of my head.benonymus
this is how the assings look
I am trying to upload an file in form data
benonymus
yes it only happens in production there it gives back the html error altough i’d prefer the json in both cases
benonymus
I was able to make it arrive here:
but at the end it still put out the empty 500 error
and it logs out this:
the same as with the 500 earlier
OvermindDL1
You are returning a structure from the render function instead of a binary. If you want it to return json then you need to convert it to json instead of an elixir map.
Other than that you shouldn’t need to return any body for a 413 as the status code itself already told the issue, that’s not the body’s job.
jola
That can’t be right, I’m returning maps from my render functions and I get JSON. I couldn’t tell you why though, is it inferred from the view name?
Also, the post author says it works with
MIX_ENV=dev, it just fails withprod, which made me suggest it is config related.Edit: Googled a bit and the Phoenix View documentation shows rendering JSON from a map in an example. So it should work.
https://hexdocs.pm/phoenix/Phoenix.View.html#module-rendering
benonymus
Yeah, I ended up doing this, and also the guy who wanted it figured it out that the status code is enough for him too… Thank you for the answer