Does anyone know of instructions to setup Elixir with NVChad and Neovim?

I’ve been trying to get this to work for many hours following documentation and just running into more problems. None of these are explicit instructions. Does anyone know of such instructions I could follow?
Thank You.

Hi @blinux can you show links to what you’ve tried so far?

This is the document page from NVChad for the LSP server. I was mostly working off of this.

You can find a ton of GitHub repos by starting e.g. from here:

I know @fuelen has NeoVim config for Elixir and others here: GitHub - fuelen/nvimfiles: Configuration files for NeoVim

I personally use LunarVim and I am super happy with it, added configs for Elixir, Golang and Rust and everything I need so far has been rock-solid.

I’ve tried installing the elixir-ls with Mason and that installed fine. The problem is that it is not attached to the buffer when opening elixir files. It appears that to do that I have to add it to local servers = { “html”, “cssls”, “clangd”} list, but it still doesn’t work. I tried adding both elixirls and elixir-ls one at a time since I wasn’t sure which it should be.

The page says to add “require’lspconfig’.elixirls.setup{}” to enable the server, but I’m not clear were to add this. I have too many questions and was hoping to just find some instructions.

How do I find the path to I see this says to add it this:

cmd = { “/path/to/elixir-ls/” };

It also says to add a snippet to enable the server with .setup{}, but isn’t that the same thing and is thatin the init.lua as well?

Also there is a new language server called nextls which isn’t even listed here.

To setup NVChad / Neovim for Elixir do this:

  1. GitHub - elixir-tools/elixir-tools.nvim: Neovim plugin for Elixir (install this)
    -Put code snippet for lazy.nvim code snippet in ~/.config/nvim/lua/custom/plugings.lua
    -NVChad uses lazy.nvim for the plugins so that is why you use the lazy.nvim code snippet version.
  2. Run “TSInstall elixir” (for syntax highlighting)
  3. Use the Kitty terminal because it is needed to display fonts correctly
  4. Install Nerfonts from and copy to ~/.local/share/fonts

Get it working?