Econnrefused with Mint

I’m getting an %Mint.TransportError{reason: :econnrefused} for a request like this:

➜ curl -v http://localhost:8888
* processing: http://localhost:8888
*   Trying [::1]:8888...
* Connected to localhost (::1) port 8888
> GET / HTTP/1.1
> Host: localhost:8888
> User-Agent: curl/8.2.1
> Accept: */*
< HTTP/1.1 200 OK
< Host: localhost:8888
< Date: Mon, 11 Sep 2023 10:24:31 GMT
< Connection: close
< X-Powered-By: PHP/8.2.9
< Content-Type: application/json
* Closing connection

But a similar request like this one works ok:

➜ curl -v http://localhost:5000
* processing: http://localhost:5000
*   Trying [::1]:5000...
* Connected to localhost (::1) port 5000
> GET / HTTP/1.1
> Host: localhost:5000
> User-Agent: curl/8.2.1
> Accept: */*
< HTTP/1.1 200 OK
< X-Powered-By: Express
< Content-Type: application/json; charset=utf-8
< Content-Length: 15
< ETag: W/"f-v/Y1JusChTxrQUzPtNAKycooOTA"
< Date: Mon, 11 Sep 2023 10:24:28 GMT
< Connection: keep-alive
< Keep-Alive: timeout=5
* Connection #0 to host localhost left intact

The second example is a standard Express server and the first one php. In the browser, curl, wget both requests work perfectly ok. Only Mint (and thus tools using Mint, like Req and Finch) gives me an error.

I can see that the responses are not exactly the same, but I don’t see why it should fail (content-length is nto a required header, and I’ve tried with setting the charset as well, but it doesn’t change the results)

Hi @tcoopman if you’re getting :econnrefused then mint is saying it can’t establish a connection at all, not that it can’t make sense of the response. Can you show your mint code?

I’ve tried with both the Req and Mint example from: GitHub - wojtekmach/mix_install_examples: A collection of simple Elixir scripts that are using Mix.install/2.
So I’m pretty sure it’s not about the code.

Also, tunneling the same request through ngrok makes it work.

Local proxy settings, maybe?

I don’t think so either. All ports work for the typescript server, none for the php server.

Well I would take out the huge hammer i.e. download Mint locally and specify that path in my mix.exs and then pepper that locally downloaded Mint with dbg. :person_shrugging:

Though it’s likely something else – maybe a security policy or some such – and it might turn out to be the wrong problem to focus on but still, you have to start somewhere.

yeah, no time to investigate currently :frowning: Might do that later though and see what’s going on…

I did find some time, and it’s an error coming from :gen_tcp.connect with these parameters:

  address: 'localhost',
  port: 5000,
  opts: [packet: :raw, mode: :binary, active: false],
  timeout: 30000

So I’m stuck…

(hint for debugging something locally, use Mix.install like this: Mix.install([{:mint, path: "."}]))

Ok, found the culprit.
Running php -S localhost:8000 results in the error, but php -S works.
I’m still confused why it’s only gen_tcp that struggles with the connection and no other tools.

curl tries to connect via both IPv4 and IPv6 while Mint probably tries only one of these (IPv4) when not asked to use IPv6 explicitly.

1 Like