Ecto.Adapters.Postgres was not compiled

phoenix
postgres
troubleshooting
erlangotp

#1

“(ArgumentError) adapter Ecto.Adapters.Postgres was not compiled, ensure it is correct and it is included as a project dependency”

I urgently need help in the Phoenix and postgres installations, something went wrong with postgres dependency when I tried to mix ecto.create , then I attempted to correct it (i changed in the mix.exs to {:postgrex, ">= 0.10.0"},… still not working), but other errors appeared. Would it be possible to guide me? Or even advise on how to uninstall the whole set, so I can do it from the beginning?

Also another problem appeared regarding erlang/OTP (it appears in the same screenshot on the right bottom.

Thank you , and hope I am not causing any inconvenience


#2

The warning in the lower right can be fixed by installing a version of elixir that has been compiled with an erlang version >= 20. How to do this depends on your system and how you installed elixir and erlang originally.

I can’t help you with the other error though.


#3
```plain
iex(9)> Pushbutton.push()     
** (exit) exited in: :gen_statem.call(:pushbutton_statem, :push, :infinity) 
    ** (EXIT) no process: the process is not alive or there's no process currently associated with the given name, possibly because its application isn't started
    (stdlib) gen.erl:228: :gen.do_for_proc/2
    (stdlib) gen_statem.erl:598: :gen_statem.call_dirty/4
iex(9)> 
```

Images are often hard to read, don’t necessarily contain all of the relevant information and are not mobile friendly.

  • Now what exactly are the details of installation/configuration? From the C:\Users\ path I suspect that you are using some version of MS Windows (hopefully 10) - if so, prefix the topic like this “Windows 10: Ecto.Adapters.Postgres was not compiled” as to attract the attention of forum members who actually develop on Windows.
    (Aside: In the days of Windows 7 I came to the conclusion that Windows got in the way more often than not for non-Microsoft centric web development - so I switched platforms)

  • What was the installation process you’ve followed (if you used a package manager - which one)?

    • Which version of Erlang is installed? (your Elixir was complied with 19 - but what is actually installed)
    • Which version of Elixir is installed?
    • Which version of Phoenix do you have installed?
    • What version of Ecto are you trying to use?

When things go wrong, things tend to get complicated fast.


#4

Well, i realised the mistake is quite silly. in the version i am using, i should have typed phx instead of phoenix when creating new project. And the other problem resolved by installing another version.
Thanks for you help. Highly appreciated


#5

thanks a lot, installing a different version worked.