Ecto Migration Can't be executed, Migration name is duplicated

Hi Everyone,

I am using Phoenix for a game application and while everything works great I am stuck with this one issue with Ecto migrations.

When running migrations no matter if the database is empty or not, it throws the following error.

(Ecto.MigrationError) migrations can’t be executed, migration name create_users is duplicated (ecto_sql) lib/ecto/migrator.ex:572: Ecto.Migrator.ensure_no_duplication!/1 (ecto_sql) lib/ecto/migrator.ex:414: Ecto.Migrator.run/4 (ecto_sql) lib/ecto/migrator.ex:142: Ecto.Migrator.with_repo/3 (game_of_fortune) lib/game_of_fortune/release.ex:10: anonymous fn/2 in GameOfFortune.Release.migrate/0 (elixir) lib/enum.ex:1948: Enum."-reduce/3-lists^foldl/2-0-"/3 (game_of_fortune) lib/game_of_fortune/release.ex:9: GameOfFortune.Release.migrate/0 (stdlib) erl_eval.erl:680: :erl_eval.do_apply/6 Build step ‘Execute shell’ marked build as failure Finished: FAILURE

I am running the migration from the release as defined in Phoenix deployment documentation.

I tried doing the same on my MacBook and it just works fine. There are no duplicate migrations in code. Its not working on ubuntu machine. I am building the release in a docker image.

PS - The local version of Postgres on Macbook is 11.5, while on the Ubuntu server its 9.5.19

Could you provide list of all migrations? ls -1 priv/repo/

1 Like

I see, You are on spot. I ran the command in /app/lib//priv/repo/migrations and got the following.

20191004084419_create_users.exs
20191009104651_add_pow_email_confirmation_to_users.exs
20191013132252_create_users.exs
20191014044857_add_pow_email_confirmation_to_users.exs
20191015100022_create_card_types.exs
20191015100106_create_cards.exs
20191015102807_update_users.exs

Here clearly the migration create_users is duplicated. But how? I don’t know same release command doesn’t produce duplicate migration on my Mac

Doesn’t pow create a migration on it’s own, when you run mix pow.install?

Confirmed it from the pow docs

Excerpt from the docs

mix pow.install

This will add the following files to your app:

LIB_PATH/users/user.ex
**PRIV_PATH/repo/migrations/TIMESTAMP_create_user.ex**

It will generate a migration: PRIV_PATH/repo/migrations/TIMESTAMP_create_user.ex so here is your duplicate in your migration.
https://hexdocs.pm/pow/README.html

I hope that your problem is solved now.

2 Likes

Thanks for your help,

This turned out to be a completely different problem. After building release in a container, our devops team rsync that to a different server and they ran rsync in incremental mode, so an old file was a leftover from a previous rsync.

Thank you very much for helping me out.

1 Like

Glad that your problem is solved