Elixir 1.10.1 on Windows crashes always

Hi, I updated elixir to 1.10.1, now I always get a crash whether I run mix hex.info or iex -S mix phx.server or any other command.
For example with iex -S mix phx.server I get this message:

“c:/Program Files (x86)/Elixir/lib/iex/ebin/Elixir.IEx.CLI.beam”
2020-02-12 15:41:33 ~s~n
“beam/beam_load.c(1862): Error loading module ‘Elixir.IEx.CLI’:\n This BEAM file was compiled for a later version of the run-time system than 20.\n To fix this, please recompile this module with an 20 compiler.\n (Use of opcode 162; this emulator supports only up to 159.)\n”
2020-02-12 15:41:33 crash_report
initial_call: {supervisor_bridge,user_sup,[‘Argument__1’]}
pid: <0.49.0>
registered_name: []
error_info: {error,undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,“user_sup.erl”},{line,100}]},{user_sup,init,1,[{file,“user_sup.erl”},{line,49}]},{supervisor_bridge,init,1,[{file,“supervisor_bridge.erl”},{line,80}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}
ancestors: [kernel_sup,<0.36.0>]
message_queue_len: 0
messages: []
links: [<0.37.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 987
stack_size: 27
reductions: 223
2020-02-12 15:41:33 supervisor_report
supervisor: {local,kernel_sup}
errorContext: start_error
reason: {undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,“user_sup.erl”},{line,100}]},{user_sup,init,1,[{file,“user_sup.erl”},{line,49}]},{supervisor_bridge,init,1,[{file,“supervisor_bridge.erl”},{line,80}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}
offender: [{pid,undefined},{id,user},{mfargs,{user_sup,start,[]}},{restart_type,temporary},{shutdown,2000},{child_type,supervisor}]
2020-02-12 15:41:33 crash_report
initial_call: {application_master,init,[‘Argument__1’,‘Argument__2’,‘Argument__3’,‘Argument__4’]}
pid: <0.35.0>
registered_name: []
error_info: {exit,{{shutdown,{failed_to_start_child,user,{undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,“user_sup.erl”},{line,100}]},{user_sup,init,1,[{file,“user_sup.erl”},{line,49}]},{supervisor_bridge,init,1,[{file,“supervisor_bridge.erl”},{line,80}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}}},{kernel,start,[normal,[]]}},[{application_master,init,4,[{file,“application_master.erl”},{line,134}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}
ancestors: [<0.34.0>]
message_queue_len: 1
messages: [{‘EXIT’,<0.36.0>,normal}]
links: [<0.34.0>,<0.33.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 987
stack_size: 27
reductions: 243
2020-02-12 15:41:33 std_info
application: kernel
exited: {{shutdown,{failed_to_start_child,user,{undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,“user_sup.erl”},{line,100}]},{user_sup,init,1,[{file,“user_sup.erl”},{line,49}]},{supervisor_bridge,init,1,[{file,“supervisor_bridge.erl”},{line,80}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}}},{kernel,start,[normal,[]]}}
type: permanent
{“Kernel pid terminated”,application_controller,"{application_start_failure,kernel,{{shutdown,{failed_to_start_child,user,{undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,“user_sup.erl”},{line,100}]},{user_sup,init,1,[{file,“user_sup.erl”},{line,49}]},{supervisor_bridge,init,1,[{file,“supervisor_bridge.erl”},{line,80}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}}},{kernel,start,[normal,[]]}}}"}
Kernel pid terminated (application_controller) ({application_start_failure,kernel,{{shutdown,{failed_to_start_child,user,{undef,[{‘Elixir.IEx.CLI’,start,[],[]},{user_sup,start_user,3,[{file,"user_sup.

Crash dump is being written to: erl_crash.dump…done

Does version 1.10.1 on Windows work for someone?
BTW I have the latest version of Windows and have used the normal elixir-websetup.exe.

Elixir 1.10 requires at least Erlang OTP 21, though your system seems to still run OTP 20. You need to update your OTP version.


Thanks, but I haven’t installed Erlang, as far as I know Erlang is installed or updated by the elixir-websetup.exe or no?

Yes, it installs erlang, though it offers to install erlang 21 when I try it.

I can’t test which version will be actually installed, I do not want to have erlang or elixir installed on the windows host.

A post was split to a new topic: Can’t compile elixir 1.10.1 on CentOS 7

I just tried the elixir-websetup.exe again, there is no choice if I want to install erlang 21.

I’d suggest you try installing both Erlang and Elixir through asdf and check if the problem persists.

Have you forced to redownload it from the website? Also, have you removed erlang first? Perhaps the installer won’t offer to isntall erlang when it finds one.

asdf-vm does not support windows natively, its only possible by installing a good bunch of other tools.

Thanks for the suggestion, but it doesn’t make sense to me. I have often used Elixir with the elixir-websetup.exe (for 2 years now) and it has always worked. Why should it not work now?

1 Like

When I installed Elixir 1.10 in Windows 10 it asked to install Erlang. Maybe uninstall both Erlang and Elixir and try again.

Yes, I will try it, but it does not help to improve the elixir web setup, this is what the setup should do and what it has always done until now.

In that case uninstall what you had and first install Erlang 21 or 22 separately, and then Elixir.

“Should work” yep okay, but it doesn’t. :slightly_smiling_face: Try this method and let’s take it from there.

@Werner Perhaps you could try installing it through a package manager to make it a little bit easier:


choco install -y erlang
choco install -y elixir


scoop install erlang
scoop install elixir

Please, check the available versions for both Chocolatey and Scoop.
For Scoop at least, the main buckets are up to date:

PS: Scoop has also a nifty built-in way to manage installed versions

1 Like

Uninstall BOTH Elixir AND Erlang, then make a clean Elixir install. There’s no need to use Chocolatey.
You could of course install Erlang separately, that should fix the issue too, but just uninstalling them and re-running the Elixir web installer works fine.

Also, check your PATH to make sure windows looks for Erlang at the correct path.