Elixir function doesn't continue if takes too long

def func do
IO.puts(“Conversion done, starting to upload”)

I have this function, but problem is, if convert_video.(1280) takes too long, IO.puts(“Conversion done, starting to upload”) line does not execute, infact nothing after executes.
However if convert_video.(1280) takes short time, all the codes below executes.

How to make sure function always executes fully?

Obvious question sorry but how are you sure that convert_video.(...) has finished?

it’s just calling a system command for ffmpeg, I can monitor the porgress as well as the process in the os, if they are still there. And I can see they are done. I also tried leaving it for more then an hour. It just does nothing.
If I call other functions (via Phoenix api), it runs, even the same function as well. Just doesn’t execute the rest of the code if the convert_video() takes long.

I am far from an expert but maybe ffmpeg does not send EOF to stdout (if that is even a thing…). Can you try with the rambo library?

That might be a case, trying that now. thank you ~

A function always executes until it is completed.


Also what you can do is register your process to give it a name:

def func do
  Process.register(self(), :hello)
  IO.puts("Conversion done, starting to upload")

Then start your app with iex (like iex -S mix phx.server if using Phoenix) and run a single long conversion (otherwise process registration will clash), and once you see in the OS that it is finished, you can call this in IEx:

pid = Process.whereis(:hello)

This will return a pid, or nil. If it returns nil it means that your function either crashed silently, for some reason, or completed but you could not see the output of IO.puts for some reason (but it was executed as Robert says).

If you get a pid, then your process is still awaiting something, or looping forever somewhere. You can then call this in IEx shell:

Process.info(pid, :current_stacktrace)

This will show what is that process doing at the moment.

For instance if for some reason the process is still awaiting a return from a system command, you may see this:

iex(7)> pid = spawn(fn -> System.cmd("watch", ["sleep", "1000"]) end)
iex(8)> Process.info(pid, :current_stacktrace)
   {System, :do_port_byte, 3, [file: ~c"lib/system.ex", line: 1118]},
   {System, :do_cmd, 3, [file: ~c"lib/system.ex", line: 1107]},
   {:elixir, :eval_external_handler, 3, [file: ~c"src/elixir.erl", line: 396]}

That was really helpful, Thank you very much ~
So, I found out, the process was returing nil after a while, then I realized it was the phoenix timeout after 60 seconds by default.
So I increased the default timeout behaviour, and now it works. Alhamdulillah ~
Thanks again, May Allah return the favour upon you in a greater way ~


Consider marking @lud’s answer as the solution. It helps future readers.