Elixir v1.8.0-rc.1 released

Hi everyone,

We have just released Elixir v1.8.0-rc.1. It contains only one bug fix compared to v1.8.0-rc.0. You can read the previous and complete CHANGELOG here.

If you haven’t tried v1.8.0 out yet, please give it a try and give us feedback. If everything “just works™”, please let us know that too. Your feedback is really important! If no more bugs are reported, the final release will be done next week.

To try it out, you can either compile the v1.8 branch from source OR use the precompiled files, as described in our install page. But if you are on Windows, you can simply use the installer.

Happy New Year!


I can’t seem to install 1.8.0-rc.1 or 1.8.0-rc.1-otp-21 via asdf. When I run asdf install elixir 1.8.0-rc.1-otp-21 or asdf install elixir 1.8.0-rc.1 the plugin reports that the .zip file cannot be found.

When I run asdf list-all elixir both 1.8.0-rc.0 & 1.8.0-rc.1 are listed as available.

When I run asdf uninstall elixir 1.8.0-rc.0-otp-21 and then asdf install elixir 1.8.0-rc.0-otp-21 to reinstall 1.8.0-rc.0, it downloads and installs fine.

Is anyone else having this issue?

Can confirm that asdf install elixir 1.8.0-rc.1-otp-21 fails.

1 Like

@l00ker and @tcoopman same here.
@josevalim any luck with fixing your tools for uploading docs and releases?

asdf install elixir ref:v1.8.0-rc.1 works :077:

And I found no issues when testing the new rc1 on a couple of my projects!

1 Like

Yes, I have that problem too. This happened before with new releases and there is a github issue on the asdf elixir plugin discussing it: https://github.com/asdf-vm/asdf-elixir/issues/18.

1 Like

Yes, I use that too. It works because it compiles the specified source instead of downloading a pre-compiled version (that apparently isn’t available yet).

No problems with any of my existing projects, either. Looking forward to using the final release soon.

1 Like

With asdf, compiling from source works:

asdf install elixir ref:32825ebaa0c1f6785dcd30d87f0ade45cd6c20cb

Thanks for this! Was facing a similar issue.

1.8.0-rc.1-otp-21 is now available in asdf it seems. :slight_smile:


I stumbled into this on latest master https://github.com/plataformatec/nimble_csv/issues/36. Works fine on rc.1


You are a saint. Thanks for using master, we will check it!