ElixirLS crashing after upgrading to Ventura

Hello. I am having ElixirLS crash on me suddenly. This is what the log messages say: ElixirLS Crash Log - Pastebin.com (TL;DR elixir: not found followed by Connection to server got closed. Server will restart.

Only thing that happened between my work with Elixir from 3 hours ago and now is MacOS upgrade to OS Ventura. Also, possibly related, LiveBook isn’t showing autocomplete either. It’s going No Suggestions on me.

Elixir 1.14
Erlang 25.1.1
MacOS: Ventura (Upgraded few hours ago, was working with Elixir right before that restart and was perfectly fine)
ElixirLS: 0.11
Things tried: Different versions of Elixir (i.e. removal of -otp-24 that I had, reinstalling the extension, staring at the screen real hard and counting backwards from 99 to 1)

Any help would be great.

Maybe the permissions for executing stuff in your terminal need to be re-granted? Or maybe just reinstall the relevant Erlang / Elixir version through asdf?

I tried the asdf one to no effect. Would look into permissions. Thanks. One additional info, I get this error when trying to restart the ElixirLS server.

Looks like it was same across all LSPs. Looks like I needed an xcode-select --install now got fixed. I wish it yelled at it me the same way it yelled at me for not having git (though I clearly had it) few weeks ago to my annoyance.

Sorry for making this an ElixirLS problem where the problem was me.

1 Like

It was hard to deduct for me as well because Apple screwed up badly this time: they released XCode 14.1 at least a week after Ventura landed, leaving a lot of people with the inability to even update various homebrew packages in the meantime.


I’ll also leave a strong suggestion for people updating xcode to download it from the developer website and not update through the app store. The latter seems to be flaky in applying the update and doesn’t even cache the GBs of downloads it tries to apply, redownloading things if there are errors.


Had to wait before moving to Ventura, took a couple of retries to get things back up and running just fine.

I posted about it as well. After fixing it. :sweat_smile:

1 Like

Yeah I saw that one. Also wished it were written a few days earlier :frowning: