Emacs Elixir syntax checking not working

I use Emacs and have the following code in my init.el:

   (use-package elixir-mode
      :ensure t
      :hook (elixir-mode . (lambda ()
                            (add-hook 'before-save-hook 'elixir-format nil t))))

    ;; Alchemist offers integration with the Mix tool.
    (use-package alchemist
      :ensure t
      :hook (elixir-mode . alchemist-mode)
      :delight alchemist-mode)

    (use-package flycheck-mix
      :ensure t
      :init (add-hook 'flycheck-mode-hook #'flycheck-credo-setup))

    (use-package flycheck-credo
      :ensure t
      :defer t
      :init (add-hook 'flycheck-mode-hook #'flycheck-credo-setup))

At the moment I can’t get flycheck syntax checking to work. What am I doing wrong?

1 Like

I’m not using use-package, therefore I can only guess.

I can’t see here that you associate flycheck-mode to elixir-mode. So unless you do global-flycheck-mode anywere, you need to (add-hook 'elixir-mode-hook flycheck-mode) at a place where it is appropriate, maybe use-package has some special syntax for it.

PS: Even though I generally prefer emacs over everything else, I currently use VScode for elixir, because language server support is so much better. I hope LS support will be available in alchemist.el soon!

1 Like

Yes I do have

(use-package flycheck
  :ensure t
  :delight " ✓"
  :init (global-flycheck-mode))

and I also noticed that I had

(use-package flycheck-mix
  :ensure t
  :init (add-hook 'flycheck-mode-hook #'flycheck-credo-setup))

instead of

(use-package flycheck-mix
  :ensure t
  :init (add-hook 'flycheck-mode-hook #'flycheck-mix-setup))

but that hasn’t solved my problem. I’ll look into VScode as suggested.

When you are in an elixir buffer, have you tried M-x flycheck-mix-setup RET?

I’m not sure how :init works in use-package. To be honest, I do not see much sense in it. I prefer a simple helper function which installs packages when required and plain elisp, that makes it much easier to understand what is going on…

Okay, I took a closer look at use-packages documentation. As I understand it, :defer t will defer loading the package to the latest point possible, while :init will only be called when the package is loaded, this might mean, that you only add to the hook after it has already been applied.

And again, since I am not using use-package, I’m not sure if I understand the docs correctly, or if I do, how to workaround.

I usually have (add-hook 'flycheck-mode-hook #'flycheck-foo-setup) plain in the config, while I also have (add-hook 'after-init-hook 'global-flycheck-mode) at the toplevel of my config.

This way, I fill up the hook during load time, while postponing the start of flycheck until after init has fully been evaluated.

But maybe, it helps when you add flycheck-credo-setup into elixir-mode-hook? But still, I’m not sure if you should :defer

I’ve made the changes you suggested but unfortunately i’m still not getting any flycheck support for my scripts. Anyway VSCode seems to be doing a much better job for me at the moment so I’ll defer using Emacs for Elixir coding for later when hopefully the tools improve. Thanks again you’ve been very helpful.

Make sure you can run credo from command line.
Add credo dependency to mix.exs:

defp deps do
      {:credo, "~> 1.4", only: [:dev, :test], runtime: false}  

download and run credo:

mix deps.get

mix credo

My emacs setup works fine:

(use-package elixir-mode)

(use-package alchemist-mode
  :ensure alchemist
  :hook elixir-mode
  :bind (:map elixir-mode-map
	      ("s-c" . alchemist-iex-compile-this-buffer)
	      ("C-c C-l" . alchemist-iex-project-run)))

(use-package company
  (add-hook 'elixir-mode-hook 'company-mode)
  :bind (:map elixir-mode-map
	      ("TAB" . company-indent-or-complete-common)))

(use-package flycheck-mode
  :hook elixir-mode
  :ensure flycheck
  (use-package flycheck-credo)

Also you could try M-x flycheck-verify-setup

It should print something like:

First checker to run:

- may enable: yes
- executable: Found at /Users/maris/.kiex/elixirs/elixir-1.10.3/bin/mix

Thanks @maruks for answering my post. I’ve moved to now using doom-emacs and it’s elixir setup which works okay for my needs. I can therefore not confirm if your solution works for my situation or not. I’ve however made a note and will revert to it should I find the need to role out my own emacs config again. Cheers.

Do you use Doom Emacs with Alchemist? If so, does it work well?

@dimitarvp yes I do and below is my config:

;; Elixir
(after! lsp-mode
  (defun dap-elixir--populate-start-file-args (conf)
    "Populate CONF with the required arguments."
    (-> conf
        (dap--put-if-absent :dap-server-path `("~/lang_servers/elixir-ls/release/debugger.sh"))
        (dap--put-if-absent :type "mix_task")
        (dap--put-if-absent :name "mix test")
        (dap--put-if-absent :request "launch")
        (dap--put-if-absent :task "test")
        (dap--put-if-absent :taskArgs (list "--trace"))
        (dap--put-if-absent :projectDir (lsp-find-session-folder (lsp-session) (buffer-file-name)))
        (dap--put-if-absent :cwd (lsp-find-session-folder (lsp-session) (buffer-file-name)))
        (dap--put-if-absent :requireFiles (list

  (dap-register-debug-provider "Elixir" 'dap-elixir--populate-start-file-args)
  (dap-register-debug-template "Elixir Run Configuration"
                              (list :type "Elixir"
                                    :cwd nil
                                    :request "launch"
                                    :program nil
                                    :name "Elixir::Run"))

  ;; Enable formatting on save and send reload command to Elixir’s REPL
  (add-hook 'elixir-mode-hook
            (lambda ()
              (add-hook 'before-save-hook 'lsp-format-buffer nil t)
              (add-hook 'after-save-hook 'alchemist-iex-reload-module))))

;; Configure ExUnit package
(use-package! exunit)

;; Disable popup quitting for Elixir’s REPL
(set-popup-rule! "^\\*Alchemist-IEx" :quit nil :size 0.3)


1 Like