[EMACS] "no match" on package-install

Obviously, I am a new Emacs user and I can’t seem to figure out how to install either alchemist or elixir-mode, every time I’m trying to run M-x package-install [RET] alchemist [RET] I get no match.

Any ideas on how to fix this? I had a look online and tried most of the solutions I could find but nothing seems to work.

OS: Archlinux

Have you activated MELPA as a package repository? If not please follow instructions on https://melpa.org/#/getting-started

Tried that.
Added the needed configuration in .emacs but the results are the same.

Have you tried M-x list-packages [RET] as well? Is alchemist or anything else from MELPA listed there?

Might be that the function name was a little bit different but something along that lines.


I find spacemacs a good introduction if you’re a new Emacs user. You have MELPA already configured among other things. I’ve had no problems adding packages to it (and alchemist works great with spacemacs).

Agree… Spacemacs is just lovely. I know about it because of the alchemist.

SPC f e d, then put elixir on the layer,

then restart the spacemacs.

1 Like

Loving spacemacs so far, thanks @bobbypriambodo