Enabling audio on Nerves with Raspberry Pi


As we don’t have “stickies” or “FAQs” sections yet, I’m posting this in “Discussions”.

Audio on Nerves Raspberry Pi

We’ve received a few questions about enabling/using audio on raspberry pi devices. We’ve had an issue on the RPI3 nerves_system open since late 2017, and we will likely at some point enable these features in the default systems in the future, but for anyone looking for a way to get started today can follow along here.


First We will need to follow the Customizing a Nerves System guide.

Raspberry Pi Kernel changes

Nerves currently enabled sound kernel modules on all the Raspberry Pi models. You should not need to modify anything here.

Raspberry Pi config.txt changes

We will need to follow the Boot partition overwrite guide for this step. We will be overwriting the config.txt file. You can read more about that file and its supported values here.

Find the lines


and change the last to:


User packages for audio

Now we can simply enable any audio programs in Buildroot. Let’s setup espeak and alsa-utils for example.

Open the Buildroot configuration utility:

make menuconfig

You can use / to open the search menu. Look for espeak. Once found it can simply be enabled.
Do the same for aplay.

after saved we will end up with some new lines in nerves_defconfig:



And that’s it. This is more an exercise in finding/enabling packages in Buildroot. Hopefully this will be useful to some.
This guide does apply to more than simply Raspberry Pi devices, but the config.txt part is Raspberry Pi specific.


I’ve been hoping for a guide for this for over a year now. Thank you very much!


I’ve heard from so many people on this topic. Thanks for all of the comments. My plan had been to update the official Raspberry Pi Nerves systems to Linux 4.14 (they’re still on 4.4) and then integrate at least aplay and make a release. Little did I know that we’d run into two fairly big issues with Linux 4.14. One is a flakiness with wired Ethernet on the 3 B+ (see https://github.com/raspberrypi/linux/issues/2447). It seems fixed for me now, but… The other was a big change with Linux 4.14 on the BBB with how device tree overlays work, and that delayed work on the RPi. It’s working, but needs better docs. In better news, Google’s AIY voice kit’s audio hat only works with 4.14 and it’s been working well. Thanks everyone for the patience. I’ll post again soon.



Hello… I have plugged a regular stereo speaker into PI audio port and nothing is coming out. Also I used a single 3.5mm cable to connect PI to audio input in LCD HDTV and still not audio, NO audio also from HDMI cable connection.

@AndyFrew Can you elaborate a bit? how are you trying to get audio out? aplay? espeak? Do you see any errors in your console? What rpi variant are you using? Audio goes through the 3.5mm connector by default, i think you can enable HDMI audio out in config.txt but i’ve never done it before.

1 Like