Ensure_migrations_paths/2 is undefined while running tests. I am using Ash 3.0

My tests are failing with the following error. I am using Ash 3.0. What could I be missing?
I have replaced the normal Ecto Repo with Ash Repo. I am able to do CRUD in the browser, but tests are failing with below error:

Running tests...
Compiling 1 file (.ex)
** (UndefinedFunctionError) function Mix.EctoSQL.ensure_migrations_paths/2 is undefined (module Mix.EctoSQL is not available)
    Mix.EctoSQL.ensure_migrations_paths(Kamaro.Repo, [all: true, quiet: true, log: false, log_migrations_sql: false, log_migrator_sql: false])
    (ecto_sql 3.11.1) lib/mix/tasks/ecto.migrate.ex:141: anonymous fn/5 in Mix.Tasks.Ecto.Migrate.run/2
    (elixir 1.16.2) lib/enum.ex:2528: Enum."-reduce/3-lists^foldl/2-0-"/3
    (ecto_sql 3.11.1) lib/mix/tasks/ecto.migrate.ex:139: Mix.Tasks.Ecto.Migrate.run/2
    (mix 1.16.2) lib/mix/task.ex:478: anonymous fn/3 in Mix.Task.run_task/5
    (mix 1.16.2) lib/mix/task.ex:544: Mix.Task.run_alias/6
    (mix 1.16.2) lib/mix/cli.ex:96: Mix.CLI.run_task/2
    c:/Program Files/Elixir/bin/mix:2: (file)

:thinking: that seems pretty strange? What is your ecto/ecto_sql version? Have you tried deleting your _build folder and rebuilding from scratch?

Removing _build and recompiling again solved the problem.