Erl_child_setup closed

troubleshooting
#1

i am getting erl_child_setup closed error at every run , both by running iex and using exilixir file.exs

i am using elixir on arch for arm inside termux via ssh

 root@localhost
                  .o+`                   --------------
                 `ooo/                   OS: Arch Linux ARM armv7l
                `+oooo:                  Kernel: 3.4.42-g89906d6
               `+oooooo:                 Uptime: 20 hours, 25 mins
               -+oooooo+:                Shell: bash 5.0.0
             `/:-:++oooo+:               Terminal: proot
            `/++++/+++++++:              CPU: Qualcomm MSM8226 (4) @ 1.190GHz
           `/++++++++++++++:             Memory: 546MiB / 888MiB
          `/+++ooooooooooooo/`
         ./ooosssso++osssssso+`
        .oossssso-````/ossssss+`
       -osssssso.      :ssssssso.
      :osssssss/        osssso+++.
     /ossssssss/        +ssssooo/-
   `/ossssso+/:-        -:/+osssso+-
  `+sso+:-`                 `.-/+oso:
 `++:.                           `-/+/
 .`                                 `/
0 Likes

#2

Could you please provide the full error message?

Also please tell us the ouput of erl -version and elixir --version.

If one of these gives an error, please tell us the exact packages you have installed and their versions according to pacman.

If you have not used versions from your central repository, you might need to tell us where you got them and how you built and installed them.

0 Likes

#3

elixir version is 1.8.1-1 , cannot find out erl version as even --version flag causes it to crash

i

0 Likes

#4

Wait? What? erl -version leads to a crash? Please tell us the exact output you see when it crashes.

0 Likes

#5

i told you the exact output , i cannot post screenshot

[root19:12work]$ erl
erl_child_setup closed

Crash dump is being written to: erl_crash.dump...done
[root19:13work]$
0 Likes

#6

How have you installed erlang? Have you tried forcing a reinstallation or even tried to build it from the ABS (or the arch linux arm equivalent)?

0 Likes

#7

nothing out of normal
good old pacman -S elixir

0 Likes

#8

So erlang-nox was installed along that as a dependency?

Can you please try building it from the ABS (or your equivalent) and install that, to check if it has the same problem?

To be honest, I fear this is related to your operating system and platform combination. You might need seek out for support in the arch linux arm community.

Still, could you please check the output of pacman -Q erlang-nox?

0 Likes

#9
[root19:13work]$ pacman -Q erlang-nox
erlang-nox 21.2-1
[root19:32work]$

can i try building eralang vm from source?

0 Likes

#10

Preferably you build it from the ABS first and check if it works then. This way we could learn if there is an error in the uploaded package or if it is the package build instructions that may be faulty.

Only if that fails, try to remove erlang and elixir from your system and build them from the very scratch.

If at least one of this actually works and makes you ending up with a working version of erlang, you might need to seek support in the arch linux arm community to actually repair the packages.

0 Likes

#11

i think my platform combination can be blamed

0 Likes