Erlang brew package has the JIT disabled - should it be enabled by default?

:wave:

Hey folks!

So, this may be me not knowing how to interact with brew maintainers or Mac.

It seems like current versions of erlang on brew do not have the JIT enabled, despite being 26.2.2.

How do I know? Well, there is a benchee test that’s failing :sweat: And emu_flavor is returning :emu instead of :jit:

"26.2.2"
emu flavor: :emu

It used to work but seems to have broken in the past weeks. I can’t find anything suspicious in the brew formula. Other OSs also work fine, naturally.

I checked that this isn’t just a github action/CI behavior by running brew install erlang on my partners’ mac (still an intel mac) and it also reported the emu flavor.

Does anyone have an idea where to dig/report/fix this behavior or why it is like that? I don’t think it’s on purpose, the default experience should be the “JIT” experience by now.

I’m asking for the erlang experience on Mac, I’m going ahead and disabling the test on mac now :sweat_smile:

1 Like

That’s expected as of 26.2.2, which disabled the jit on intel based macs: asmjit+macos+x86: ephemeral "Verifying shm-id-XXXXXXXXXXXXXXXX" security popups appear during each invocation of erlang · Issue #8043 · erlang/otp · GitHub

4 Likes

This is related to the super annoying small popup you get on Intel Macs when JIT is enabled.

Check this thread for context: Popup appears for a fraction of a second whenever a mix task is run (verifying shm-id-F8BD8E...)

Disabling the JIT is a workaround to avoid the popup. A proper fix will come in OTP 27 which is I think due in May 2024.

5 Likes

@LostKobrakai @dimitarvp thank you as always! I read the changelog to identify that this isn’t wanted behavior but couldn’t find anything but maybe I was too tired :sweat_smile:

So, thanks a lot for solving this mystery for me :dancer:

1 Like