Erlang OTP-22.3.4.17 released!

A new Erlang news item has been posted!

Posted via Devtalk.

FYI, I can’t install this through asdf (and asdf is on its latest version). Tried MACOSX_DEPLOYMENT_TARGET=10.0 asdf install erlang 22.3.4.17 as well but that didn’t work either.

On macOS 11.2.3.

works here fwiw - maybe give it another go? (same os etc - didn’t even have to update asdf erlang plugin or anything)

What would repeating it achieve? But yes, I tried like 4 more times. The bottom of the log file contains this:

./configure '--enable-darwin-64bit' '--with-ssl=/usr/local/opt/openssl@1.1' '--prefix=/Users/dimi/.asdf/plugins/erlang/kerl-home/builds/asdf_22.3.4.17/release_22.3.4.17' LDFLAGS='-L/usr/local/opt/python@3.8/lib' --disable-option-checking --cache-file=/dev/null --srcdir="/Users/dimi/.asdf/plugins/erlang/kerl-home/builds/asdf_22.3.4.17/otp_src_22.3.4.17/make"
configure: error: cannot find required auxiliary files: install-sh config.guess config.sub

Which I am not sure what to make of. The only thing coming to mind is that I have both Python 3.8 and 3.9 installed and maybe homebrew messed the directory symlinks but beyond that, zero clue what to even try.

1 Like

btw: Unable to install multiple versions on Arch linux · Issue #189 · asdf-vm/asdf-erlang · GitHub

weird, seems related to autoconf… I have:

➜ ~ autoconf -V

autoconf (GNU Autoconf) 2.69

so most likely why mine succeeds. what is your autoconf -V ?

Works fine with asdf v0.8.0-rc1-e0142ee (need to bump) + ubuntu 20.04 and autoconf 2.69.

My autoconf is 2.71 and it’s the GNU one (not the one coming with macOS).

I have the same issue, and believe its linked to autoconf 2.71 (current homebrew version).

I have opened a ticket here with more details: MacOS Big Sur + Erlang 22.3 + AutoConf -> cannot find required auxiliary files: install-sh config.guess config.sub · Issue #195 · asdf-vm/asdf-erlang · GitHub

1 Like

Thanks.

I am pretty sure I have all the dependencies installed for at least 18 months now since I was able to install a lot of Erlang versions through asdf (namely compiled from source).

So it has to be something else. autoconf version looks like a solid candidate.

Ran into the same issue when attempting to install 23.0.2, downgraded autoconf version and it successfully installed.

Steps I followed:

brew uninstall autoconf --igonre-dependencies
cd
curl -O -L http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gz
tar -xzf autoconf-2.69.tar.gz
cd autoconf-2.69
./configure
make
sudo make install
2 Likes