erlexec: cannot execute binary file

I’m trying to build a Phoenix app using Docker, to later deploy it to dedicated servers

I followed this tutorial but used centos:7 as a base image instead because the dedicated servers are running that distro.

The build process works fine, but when in shell into the container to test the release I get the following:

[root@f02a27a87345 topo_master]# bin/topo_master start
/app/_build/prod/rel/topo_master/releases/1.4.0/../../erts-14.2.1/bin/erl: line 12: /app/_build/prod/rel/topo_master/erts-14.2.1/bin/erlexec: cannot execute binary file
/app/_build/prod/rel/topo_master/releases/1.4.0/../../erts-14.2.1/bin/erl: line 12: /app/_build/prod/rel/topo_master/erts-14.2.1/bin/erlexec: Success

When I cd into /app/_build/prod/rel/topo_master/erts-14.2.1/bin
I get the following error:

[root@f02a27a87345 bin]# erlexec
bash: erlexec: command not found

Any idea what could be going on?
I’m running Docker version 24.0.7, build afdd53b4e3
on a M1 Mac on MacOS 14.1.2 (23B92)

If you are building it on your mac, you are most probably building the image for ARM, while your classical server is using x86-64. For cross-compilation I think you need to setup qemu locally.

1 Like

But I’m creating the release on the same container where I’m trying to run it later, shouldn’t that work?

Can you post your entire Dockerfile?

It doesn’t matter where you create the release, it matters what machine creates the release. You are copying the compiled runtime from your system into the container.

FROM centos:7 as build

SHELL ["/bin/bash", "-c"]

# ENV HOME=/opt/build

# Set the right versions

  yum update -y && \
  yum install -y epel-release && \
  yum install -y \
  autoconf \
  curl \
  gcc \
  gcc-c++ \
  git \
  glibc-devel \
  java-1.8.0-openjdk-devel \
  make \
  ncurses-devel \
  openssl-devel \
  unzip \
  wget \

RUN git clone ~/.asdf --branch v0.13.1 && \
  echo '. $HOME/.asdf/' >> ~/.bashrc

RUN source ~/.bashrc && \
  asdf plugin add erlang && \
  asdf plugin add elixir && \
  asdf install erlang $ERLANG_VERSION && \
  asdf install elixir $ELIXIR_VERSION && \
  asdf global erlang $ERLANG_VERSION && \
  asdf global elixir $ELIXIR_VERSION

# Install build tools
RUN source ~/.bashrc && mix do local.rebar --force, local.hex -if-missing --force

RUN mkdir /app
COPY ./ /app

# Elixir release
RUN source ~/.bashrc && mix do deps.get --only prod, compile, release --overwrite

# Make a release archive
RUN tar -zcvf /app/release.tar.gz -C /app/_build/prod/rel/topo_master .

Even if I do this?

docker build . --file --tag topomaster
docker run -it topomaster /app/_build/prod/rel/topo_master/bin/topo_master start

As I understand I’m building the release inside the container, and then trying to run it inside such same container, so it should work unless I’m misunderstanding how docker build works :confused:

You want to say that running the docker image on your local machine also doesn’t work?

Sorry… I don’t understand what you mean

OK, that’s a really weird way of installing Erlang and Elixir but there are likely not many officially blessed ways under CentOS – not an expert on it.

Still, I am curious why didn’t you use Hex.PM’s official Docker images?

Have you also tried put CMD /bin/topo_master start at the end of the Dockerfile so you don’t have to get inside it to start the app?

These might not be strongly related to your problem but I’d go through such a laundry list to make sure it’s not something in earlier stages of the deployment decisions.

I tried adding CMD /app/_build/prod/rel/topo_master/bin/topo_master start but I get the same error

Still, I am curious why didn’t you use Hex.PM’s official Docker images?

  1. The dedicated servers where we need to deploy the app are running Centos 7 sadly :frowning:
  2. I didn’t know about those images, thanks for sharing

Can’t you install already compiled Erlang for CentOS 7 btw?

I don’t think the have the latest version.
I tried the approach you suggested using those docker images from hexpm and now I get a slightly different error:

root@ca9d0e762504:/app# _build/prod/rel/topo_master/bin/topo_master start
/app/_build/prod/rel/topo_master/releases/1.4.0/../../erts-14.2.1/bin/erl: 12: exec: /app/_build/prod/rel/topo_master/erts-14.2.1/bin/erlexec: Exec format error

Dunno man, sounds like you are compiling for a different CPU architecture to me. :thinking:

One example on SO (though with Golang): shell - "Exec format error" with docker run command - Stack Overflow

You should double check. Are you building inside the CentOS 7 container and then just copying the release to the baremetal CentOS 7 machines? If so, it can still be a mismatch e.g. the build container is having a x64 CPU and the prod machines use ARM?

I finally found the issue… the problem is that when I was copying the files to the container, I was also copying the _build and deps folders from my machine, and that is where everything got mixed.
Added a .dockerignore to exclude those folders and at least now the app tries to start… got a whole set of errors now but a lot less obscure.

Thanks for the help

Cool. If you’re still stuck then feel free to post the less obscure errors.