Error compiling Front-end React-Apollo code in course by Pragmatic Studio

Hello I am just starting my front-end React-Apollo app with pragmatic studio and when I went through the instructions which are the following, I ended up getting the following error:

**error I am getting : **

‘’'Failed to compile.

Module not found: Can’t resolve ‘graphql’ in ‘/Users/kimberlybrooke/Downloads/pragstudio-unpacked-graphql-code/getaways/frontend/node_modules/graphql-tag/lib’

Instructions I followed:

To start the frontend React app:

  1. In a separate terminal session, change into the getaways/frontend directory:

cd getaways/frontend

  1. Next, install the NPM package dependencies:

npm install

You’ll see some warnings from external packages. It’s nothing to worry about.
3. Now you’re ready to start the development server:

npm start

  1. And now if you browse to http://localhost:3000/ you should see all the vacation places listed on the home page of the Getaways app!


Try to go into getaways/frontend, and run…

npm outdated

js is always moving fast, and it’s hard to follow :slight_smile:

Thank you. I ran…

npm outdated

in getaways/frontend and there was quite a bit in there. So I ran…

npm update

and re-ran

npm outdated

and there is still all of this in there…

Package Current Wanted Latest Location
bootstrap 4.6.1 4.6.1 5.1.3 getaways-react
react 16.14.0 16.14.0 17.0.2 getaways-react
react-apollo 2.5.8 2.5.8 3.1.5 getaways-react
react-day-picker 7.4.10 7.4.10 8.0.0-beta.36 getaways-react
react-dom 16.14.0 16.14.0 17.0.2 getaways-react
react-router 5.2.1 5.2.1 6.2.1 getaways-react
react-router-dom 5.3.0 5.3.0 6.2.1 getaways-react
react-scripts 4.0.3 4.0.3 5.0.0 getaways-react

I followed this course long time ago, when it came out.

I tried the source code… and it works.

Compiled successfully!

You can now view getaways-react in the browser.

  Local:            http://localhost:3000
  On Your Network:

Note that the development build is not optimized.
To create a production build, use npm run build.

I think it’s too much work if You try to update frontend to latest versions, because many packages are changing major version.

so… I got the source code, decompress, went to getaways/frontend, then npm i
for the backend, npm i --prefix assets, mix deps.get, mix compile, mix phx.server

Everything was fine and working.

Did You do something special?

what’s your nodes and npm version when you ran npm i ?