Error in gettext while compiling Phoenix app

I am getting the following error after I run iex -S phx.server

== Compilation error in file lib/budgetwise_web/gettext.ex ==
** (KeyError) key :extracted_comments not found
(gettext) lib/gettext/po/parser.ex:79: Gettext.PO.Parser.extract_extracted_comments/1
(gettext) lib/gettext/po/parser.ex:42: Gettext.PO.Parser.to_struct/1
(elixir) lib/enum.ex:1314: Enum."-map/2-lists^map/1-0-"/2
(elixir) lib/enum.ex:1314: Enum."-map/2-lists^map/1-0-"/2
(gettext) lib/gettext/po/parser.ex:24: Gettext.PO.Parser.parse_yecc_result/1
(gettext) lib/gettext/po.ex:64: Gettext.PO.parse_string/1
(gettext) lib/gettext/po.ex:126: Gettext.PO.parse_file/1
(gettext) lib/gettext/po.ex:147: Gettext.PO.parse_file!/1
(gettext) lib/gettext/compiler.ex:320: Gettext.Compiler.compile_po_file/4
(gettext) lib/gettext/compiler.ex:280: Gettext.Compiler.compile_serial_po_file/3
(elixir) lib/enum.ex:1314: Enum."-map/2-lists^map/1-0-"/2
(gettext) expanding macro: Gettext.Compiler.before_compile/1
lib/budgetwise_web/gettext.ex:1: BudgetwiseWeb.Gettext (module)
(elixir) lib/kernel/parallel_compiler.ex:206: anonymous fn/4 in Kernel.ParallelCompiler.spawn_workers/6

I am on Elixir 1.7.3 and Phoenix 1.3.4

Can you share the relevant code from this file that isn’t compiling?

defmodule BudgetwiseWeb.Gettext do

  use Gettext, otp_app: :budgetwise

This is just the code here

still no change! Plwase help

Can you put your project online? Without code it’s a bit difficult to help.

I had a similar issue with get text, in my case I was missing some tools in the erlang runtime.

Did you recently install or modify your erlang installation?

I had just upgraded the ofex library. Nothing else is changed in the environment