Error when filling out forms in LiveView: caught Error: Permission denied to access property "id"

Forms were working fine until I tried logging out and now both login and register forms emit a strange JS error. Also clicking submit on either form just leads to a forever loading screen.

JS console:

caught Error: Permission denied to access property "id"
    isPhxDestroyed dom.js:66
    getNodeKey dom_patch.js:106
    indexTree morphdom-esm.js:421
    indexTree morphdom-esm.js:427
    indexTree morphdom-esm.js:427
    indexTree morphdom-esm.js:427
    indexTree morphdom-esm.js:427
    morphdom2 morphdom-esm.js:434
    morph dom_patch.js:103
    perform dom_patch.js:289
    time live_socket.js:260
    perform dom_patch.js:258
    performPatch view.js:450
    update view.js:556
    time live_socket.js:260
    update view.js:553
    pushWithReply view.js:767
    applyDiff view.js:267
    pushWithReply view.js:765
    after live_socket.js:939
    requestDOMUpdate live_socket.js:278
    pushWithReply view.js:764
    matchReceive push.js:76
    matchReceive push.js:76

absolutely nothing is sent to the phx console - I have it on log level :debug!
The line it talks about is in phoenix_live_view dep so I thought I could maybe downgrade from 0.20.14 to 0.19.5 but still the same error.

My tests run fine, they are able to register with no problem. A member is created in the database so nothing wrong there either.

If you want to try (not an ad) you can see at and open the inspector… though I don’t think it will help.

Any help is appreciated :heart:

Might have solved this actually - I was using LibreWolf (just recently updated).
This problem doesn’t show up in Chrome or even Safari… well I guess this will at least help if someone else runs into this issue :smiley:

1 Like

Update: it appears that the problem was not even because of the browser - but because of an extension enabled - Proton Pass. When I disable this the page works fine.