esl-erlang and elixir not found while installing

I have been installing esl-erlang and elixir over the last 2 years using the following commands:

wget https://packages.erlang-solutions.com/erlang-solutions_1.0_all.deb
sudo dpkg -i erlang-solutions_1.0_all.deb
sudo apt-get update
sudo apt-get upgrade --with-new-pkgs -y
sudo apt-get install -y esl-erlang=1:21.3.2-1 elixir=1.8.1-2

However, it’s not working anymore. It says:

E: Version '1:21.3.2-1' for 'esl-erlang' was not found
E: Version '1.8.1-2' for 'elixir' was not found

I have tried with different versions and with erlang-solutions_2.0_all.deb but with no luck.

Any idea what is the problem?

Many thanks!

These packages are not maintained by the Erlang and Elixir teams. You’re better off to start using asdf to manage installed versions of tools / languages at one point.

1 Like

Do you mean these old versions? Is that the reason why I am getting a not found error?

Where can I find more information about it? It was working fine in the beginning of the year. Was this announced somewhere?

Anyway, asdf does not have the version I am looking for, which is the 1.8.1-2. It only has the 1.8.1 or the 1.8.2. The same goes with the erlang.

I also tried to install using the these commands:

wget http://packages.erlang-solutions.com/erlang/debian/pool/esl-erlang_21.3.2-1~ubuntu~bionic_amd64.deb
sudo dpkg -i esl-erlang_21.3.2-1~ubuntu~bionic_amd64.deb
wget http://packages.erlang-solutions.com/erlang/debian/pool/elixir_1.8.1-2~ubuntu~bionic_amd64.deb
sudo dpkg -i elixir_1.8.1-2~ubuntu~bionic_amd64.deb

but without any luck, it returns the following errors:

dpkg: dependency problems prevent configuration of esl-erlang:
 esl-erlang depends on libwxbase2.8-0 | libwxbase3.0-0 | libwxbase3.0-0v5; however:
  Package libwxbase2.8-0 is not installed.
  Package libwxbase3.0-0 is not installed.
  Package libwxbase3.0-0v5 is not installed.
 esl-erlang depends on libwxgtk2.8-0 | libwxgtk3.0-0 | libwxgtk3.0-0v5; however:
  Package libwxgtk2.8-0 is not installed.
  Package libwxgtk3.0-0 is not installed.
  Package libwxgtk3.0-0v5 is not installed.
 esl-erlang depends on libsctp1; however:
  Package libsctp1 is not installed.

Thanks

FWIW, those -2 suffixes aren’t official versions, they are artifact versions:

They may have been made into a .deb with different settings, but the language inside is the same.

dpkg is lower-level than apt-get: you’ll need to install the dependencies specified yourself.