Failing NIF crypto 4.8


I’m trying to deploy a phoenix app with releases on a ubuntu 16 server but fail what seems to be due to a missing NIF library.

This is the log message I get:

Mar 23 19:16:47 xx systemd[1]: Started APP service.
Mar 23 19:16:50 xx APP[16061]: 2021-03-23 19:16:50.237268
Mar 23 19:16:50 xx APP[16061]:     args: [load_failed,"Failed to load NIF library /root/APP/lib/crypto-4.8/priv/lib/crypto: ' cannot open shared object file: No such file or directory'","OpenSSL might not be installed on this system.\n"]

It has always worked when I produced the release on my old ubuntu 16 computer but right now I’m on a ubuntu 18 machine and suspect it might be something there.

I checked the openssl version on my current machine and it is 1.1.1 and then tried to upgrade openssl on the server as well but it fails with this message.
This system (linux-x86_64) is not supported
Seems hard to get around.

Unfortunately I’m not in a position to just upgrade the server. I guess I could build it in some ubuntu 16 container or similar but it would be a rather large way around.

Is there some way to force the inclusion of this specific dependancy?

There probably is one, but in this case You must update your server. Ubuntu 16.04 LTS support ends next month so whoever is responsible of upgrading that server should do it now. So just force whoever is responsible for upgrades to do their job.

EDIT: maybe it isn’t the answer You expected, or answer that helps You, but it is an answer you should be given some time ago already.

1 Like

Thank you for spelling that out.

Only having an outgoing version as image option is rather sad.

I will change provider.