Form phx-change event isn't called when using render_upload(photo, "phoenix.png") method in test case

I am writing with test case for live uploading file. However, I found form phx-change event isn’t called when using render_upload/2 method in test case but I need to call it asynchronously to perform some computations over entries.
I think it’s default behaviour of this method but I am wondering why it was built in this way.
I tried to call manually form phx-change event using render_change/3 with Task.asyc at same time to make it worked somehow but this doesn’t work for me. Is there any alternative way to come around with any solution or is there anything which I am missing?

Here is my test case

test “gallery, add photos”, %{conn: conn, gallery: gallery} do
{:ok, view, _html} = live(conn, “/galleries/#{}/photos”)

photo =
file_input(upload_view, “#addPhoto-form”, :photo, [
last_modified: 1_594_171_879_000,
name: “phoenix.png”,
content:!(Path.join(:code.priv_dir(:picsello), “/static/images/phoenix.png”)),
size: 1_396_009,
type: “image/png”

render_upload(photo, “phoenix.png”)