Git hooks - Add git hooks to Elixir projects

Hey guys, I just wanted to share a library that was being around for a while already, but I didn’t share properly until now so it can help more people :vulcan_salute:

It’s called git_hooks and the main features are:

  • Git hooks actions are configured in your project
  • Auto install the configured hooks (configurable)
  • The actions can be system commands or a script in your project

Any feedback or PRs are highly appreciated :heart:

Thank you and stay safe out there!


Hey @qgadrian, I started using git_hooks for a project and it’s working well so far. The bit that I’m stuck on is getting the hooks to auto install. Is this supposed to occur upon compilation?

I have added the dependency to my project like so:

# mix.exs
  defp deps do
      {:git_hooks, "~> 0.6.4", only: [:dev], runtime: false}

# config/dev.exs
config :git_hooks,
  auto_install: true,
  verbose: true,
  hooks: [
    pre_commit: [
      tasks: [
        {:mix_task, :compile, ["--warnings-as-errors"]},
        {:mix_task, :format, ["--check-formatted"]},
        {:mix_task, :credo, ["--strict"]}

Note that my config is inside of config/dev.exs. I also tried moving it to be inside of config/config.exs, similar to how you had it in your readme. However, in both cases I had to manually install the hooks.

Is there something I am missing?

Hey @r-c!

Is this supposed to occur upon compilation?

Correct! (here it is where in the code).

It’s weird, I just tested it myself in a new project and it worked fine :confused: Since the auto-install will run every time the dependency is compiled, could it be possible that it was already compiled in your case?

Sorry for the late response mate :pray:

1 Like

@qgadrian Hey thanks for the awesome library. I have some concerns regarding automatic installations as well. I placed some logs within the library code and found that the git hooks path that the code uses in case of mix git_hooks.install is different from the one that is generated when we use mix deps.compile.
I believe that when we use mix deps.compile it takes the git hook directory relative to the deps folder. Maybe I am wrong but just wanted to let you know.

1 Like

Did you try the latest release? I recently added support for “other cases” but the regular, monolith, standard, elixir application.

If you tried it and still have problems, can you please open an issue on GitHub with more details? Then I will take a look and help you out with it :relaxed:

1 Like

Thanks for taking the time to reply. Seems that the new release is not working as well. I will raise an issue on Github with more details.

1 Like