Graphiql broken in Chrome, anyone seen this before?

Hi all,

I’m not sure if this is at all related to Absinthe but I figured I might as well ask. For some reason Chrome stopped loading the Graphiql GUI recently and I cannot figure out how to debug it. It works fine in Safari and Firefox. I have disabled all extensions, restarted the browser, and restarted the mac. Still same error:

graphiql-workspace.min.js:1 Uncaught TypeError: Cannot read property 'forEach' of undefined
    at t.value (graphiql-workspace.min.js:1)
    at t.value (graphiql-workspace.min.js:1)
    at t.value (graphiql-workspace.min.js:1)
    at t.value (graphiql-workspace.min.js:1)
    at performInitialMount (react-dom.min.js:13)
    at p.mountComponent (react-dom.min.js:13)
    at Object.mountComponent (react-dom.min.js:14)
    at mountChildren (react-dom.min.js:14)
    at m._createInitialChildren (react-dom.min.js:13)
    at mountComponent (react-dom.min.js:13)

I asked the question on Stackoverflow here which includes more images.

Any thoughts/ideas would be greatly appreciated. Thank you

Solved. Somehow localStorage became messed up. I deleted all the keys and Graphiql loaded back up. This only took about 5 hours :man_shrugging:

Moving on :rocket:

1 Like