Has anyone had problems with the elixir plugin for intellij IDEA?

Hello everyone, personally I’m a big fan of jetbrains products and your IDE, when I saw the elixir plugin (although it’s not official obviously) caused me great excitement since it has all the features I could wish for.

However…and after configuring both erlang and elixir sdk, it seems that autocomplete only works with the projects I create from scratch inside intellij…if I try to import an existing project, with a mix file, following the instructions that appear in the readme of the plugin, I simply don’t have any autocomplete or jump to source code or any other cool functionality.

Has anyone had this problem and solved it?

thank you very much to everybody

Can you link us to the plugin that you’re using along with it’s instructions?

I’ve never managed to get the Elixir plugin to work properly. It always complains that my Elixir installation appears to be corrupt and then only syntax highlighting works, which sounds like the problem you have.

Does it complain about the Elixir SD when you set it up?

If that is the case, there are various reports of the bug in the github tracker like this one [
https://github.com/KronicDeth/intellij-elixir/issues/1278 ] but no generic resolution so far.

I use it with RubyMine and it works very well for me. I get autocomplete, jump to definition, debugger, test runner, etc.

Not sure which JetBrains IDE in particular you are using, but the single language (‘small’) IDE’s don’t have a global SDK setting like IntelliJ itself does, but once set for a project, it should remember it. You just have to remember to do it when you open an existing directory as a ‘new project’ in the IDE the first time or you’ll get a message that the Elixir Facet SDK is not defined.

Depending upon the OS and how you installed Elixir/Erlang, you may just not be pointed at the correct directory. Open the options under Elixir in the Languages & Frameworks under settings and make sure that both the Elixir and Erlang directories are pointed at legit locations for your installations. I have had situations where setting it from the top level didn’t set both correctly underneath so I always set both underneath by expanding the setting menu. I’m on OSX and have used it with both HomeBrew, and now ASDF installations of Elixir and Erlang with no problems.

If you still have problems, open an issue on GitHub or message @KronicDeth. He’s usually quite responsive and helpful.

EDIT - so I just tried it with a NEW project and you are correct that you can’t get the SDK to set for some reason. My older projects work fine. I see a few others posting the same…I just haven’t created one from scratch yet. Hopefully, he’ll have an update out soon.

EDIT #2 - OK for RM I have a work around that may be similar to what you’re doing. It seems there is a bug in the latest JetBrains IDE where it won’t let you set the main Ruby SDK if you open an existing directory as a project. In the small IDE’s the primary language SDK has to be set in order to set the Elixir SDK. Since RM is not setting the Ruby SDK, the plugin cannot set the Elixir one as an addon module. What worked for me was to create an empty Ruby project and specify a Ruby SDK. This creates literally an empty directory…then do mix new with that same directory name and let it write into that directory. The Ruby version sticks, allowing setting of the Elixir one. I think this is more a JetBrains issue than an issue with the Elixir plugin.

1 Like

I had/have on Windows, it does not work, highlighting doesn’t work correctly, there is no auto completion, if I trigger manually it keeps searching for suggestion but never shows, typing has high latency. Tested on Linux there no such issues.

hi @axelson sorry for the delay, I’m trying to configure emacs right now after have not luck with intellij idea plugin…

the url is

there is all the configuration and instructions, the plugins looks pretty amazing through for me it’s not working

@drl123 I opened an issue some time ago but I never get a solution
https://github.com/KronicDeth/intellij-elixir/issues/1382

in my case I’m using the full intellij and the problems seems to be different: new project works but importing projects not…

I’m trying to configure spacemacs (emacs) right now, it is a pity, I would have liked to use intellij, but I am trying to find the most complete and stable solutin…

thank you guys

I find the situation to be really weird I kept trying from time to time for more than a year now, and I never managed to make it work, it always complains about something, once it worked but it was dead slow and I could not inspect variables in debugger, I really don’t understand how a fresh erlang and elixir installations are not enough, the maintainer says he never has theses issues but a lot of people do, something is out of place here.

Can you perhaps put a bit more effort into describing the problems you encounter?

Perhaps even link to corresponding issues/blogpost/whatever?

I totally understand the mainintainer, when he is not able to reproduce issues, then its hard to fix them.

1 Like

I had some issues a few months back with it not finding the Elixir installations and syntax highlighting in eex templates, etc. I’m running macOS Mojave and RubyMine, but using the Elixir Plugin. What worked for me was removing the IDE entirely (including the hidden directories on OSX in ~/Library/Application Support), then doing a clean install with the latest IDE from JetBrains and then adding the plugin back in. Since then, it’s been working well. Very snappy once the IDE has booted up. There must have been some issue with the newer versions of the IDE copying settings forward from the previous version…something was getting messed up. The clean install did the trick!

FYI - I’m on v10.6.0 of the plugin installed in v2019.1.2 of RubyMine, and macOS Mojave v10.14.5.

As @Nobbz mentioned, we could probably help you more if you provided some more details about your install, OS and exactly what sorts of problems you are having.

1 Like