Hello, i’m confusing about which version of Elixir should i install to use Phoenix, the stable version of Elixir is Elixir 1.10.3 but in the Phoenix docs there only mention to Elixir 1.6 or later, can i stick with v1.10.3 or i have to update to 1.6 or later?
Welcome to the forum!
1.6 is quite old and its amazing the team still supports it. If you are starting new then
1.10.3 is the right choice.
If you tend to use Phoenix 1.5, the minimum requirement of elixir is 1.7+
semver is the version standard that Elixir community adopts.
A version number is formatted as MAJOR.MINOR.PATCH. So:
- 1.10.3 is newer than 1.6, you should not say “update to 1.6”, but “downgrade to 1.6”.
Every framework or library has a minimal requirement of Elixir version, just like you said “Phoenix docs mention to Elixir 1.6 or later”. In this case, choose the newest version you can use.
1.6 is older than
1.10, just in case there was confusion about that. Sticking with
1.10 will work fine.
1.6 is older than 1.10…that was a big surprise for me, this changes everything, thanks guy!
6 is smaller than 10, so why is this a surprise?
Version numbers are not decimal, which trips people up from time to time. If you haven’t read this already, I’d recommend you read up on what “Semantic Versioning” link that’s linked above.