Heroku erro H10 app crashed on deploy phoenix api

Good mornig,

I am having this error when i deploy my phoenix api. I already set the environment variables but the error persists.

Process exited with status 0
2016-11-09T13:09:04.447084+00:00 heroku[router]: at=error code=H10 desc="App crashed" method=GET path="/" host=desolate-oasis-21296.herokuapp.com request_id=b9828c2f-7fec-4c7c-a03e-7e6ca1d09b89 fwd="" dyno= connect= service= status=503 bytes=
1 Like

I changed the Procfile

web: MIX_ENV=prod iex -S mix phoenix.server


web: MIX_ENV=prod mix phoenix.server

and it worked! I don’t know if this is the reason to app crash. Maybe i just needed to restart the dynos.

1 Like

it probably is. I can imagine that iex cannot bind to a terminal (since there is none) and crashes.

1 Like

but i still have same error

at=error code=H10 desc=“App crashed” method=GET path="/favicon.ico" host=peaceful-forest-55248.herokuapp.com request_id=c7c3a3e6-5a88-4ce4-bf25-1436b3da0fa2 fwd=“” dyno= connect= service= status=503 bytes= protocol=https