Highlights the colors of the LiveView Sigil ~L for Visual Studio Code

Hello guys,
I just watch the last video about LiveView of the Chris Mccord and I would like to know how to Highlights the code with color inside the Sigil of the Live View ~S"""?
The mine is just one color…

Hi @romenigld you might want to install the Elixir LS plugin for VSCode :slight_smile:

I already have installed this package but the Sigils is like the image.
Maybe some set?
Thank’s for reply @chouzar!

I’m not really sure :thinking: from the Changelog:

v0.2.25: 23 May 2019

(VS Code) Support syntax highlighting in Phoenix LiveView (.leex) files, including ~L sigil (Thanks to @rrichardsonv)

Is it updated to the latest version? Have you tried re-installing? :confused:

Yes I re-installed two times.
I notice the files who are using the Sigil ~L is with just the *.ex( like the component post_component.ex ) and not *.leex.

This should work. Perhaps you have another extension that is conflicting? What other extensions do you have installed?


Yes *.leex files are when you want to separate the markup from liveview’s lifecycle functions. But setting that aside I don’t have any more elixir plugins running with VSCode.

I’m not sure how a language server works, if its of any help this is my current configuration:

  • ElixirLS 0.3.3
  • Erlang/OTP 22
  • Elixir 1.9.4
  • WSL: Ubuntu-18.04 (plugin lives at ubuntu, not windows)

I skimmed the video and I was unable to find a single frame that would have shown a ~L sigil.

Can you please provide exact second of the video where it is seen?

All highlighted template code that I have seen was in leex files, not in sigils.

The vscode LS plugin does definitely not add any special support for ~l, ~e, L, nor ~E. It just wires them up to be recognized as sigils at all.

Yes maybe is this, I have these:

  • kkalita.dark-plus-elixir
  • zerokol.vscode-eex-beautify
  • iampeterbanjo.elixirlinter
  • elixir-lsp.elixir-ls
  • mrorz.language-gettext
  • mjmcloug.vscode-elixir

I disable one by one and nothing happens!

It begins at 6:42.

1 Like

I uninstalled the vscode-elixir.
And now work’s it was this.
Look my printscreen.

Thank you for all replies guys!


It will be good to update this page:

And put just the Elixir LS which will continue and have updates, like tells on changelog:

v0.3.3: 15 Apr 2020


1 Like

I’ve now updated that wiki to list ElixirLS before VSCode-Elixir, but I think it’s still a little bit early to call VSCode-Elixir unmaintained so I haven’t removed it.