how configure visual studio code for elixir intellisense

Hi guys, nice to meet you to the whole forum, I’m new here, I’m trying to configure visual studio code for elixir, right now the intellisense-autocomplete seems not working, I installed elixirLS inside vscode and also vscode-elixir (which seems use elixirsense) I don’t know if I need run a command line before, because seems that for elixirsense you need run a server before start coding, basically I just download the extensions inside vscode and also I compiled this and put the binaries inside my path

can you explain me a little bit how achieve intellisense inside vscode???..I need an extra step?

thank you so much guys, sorry for the super noob question

1 Like

If you have elixir in your path, you should just be able to install the extension in vscode and it should just work.

Other data that might help debug,

  1. is there any messages in the output tab of the builtin terminal?
  2. is there there anything is the .elixir_ls in your project directory (same level as your project mix.exs)

I’m having the same issue. Actually Intellisense works for elixir methods, but not for my own classes. Is it suppose to work this way?

1 Like

There are neither methods, nor classes in elixir, so I assume you are meaning functions and modules.

Can you tell us how you manage your erlang/elixir installation and how you start vs code?

If you use anything other than your systems installation of elixir and starting vs code from the GUI, you are doing it wrong.

Try starting it from the terminal you used to verify that the correct version of erlang and elixir are available.

1 Like

Yes sorry, I meant Modules and Functions.

I’m running windows, installed elixir through the installer but override OTP to use version 21.

Output of elixir -v:

Erlang/OTP 21 [erts-10.1] [64-bit] [smp:8:8] [ds:8:8:10] [async-threads:1]

Elixir 1.8.0-dev (929e58c) (compiled with Erlang/OTP 21)

I’m using the plugins vscode-elixir and ElixirLS. Autocomplete/intellisense works fine for Elixir own modules, but vscode can’t even recognize the name of my modules. When I start typing there’s no suggestion for them nad neither for the module functions.



1 Like

No, you use either one, not both. At least as far as I remember…

As soon as I’m back home, we had dinner and the kids are sleeping I can take a look again. Also I might be able to come up with some instructions to debug. I have to admit though that I’m not using windows.

So, disabling ElixirLS makes the default vscode intellisense work (it searches for used words in the document and I can select them), but then I lose the autocomplete for the Elixir modules. Disabling only vscode-elixir seems to make no difference on the mentioned problem - I have autocomplete on Elixir modules but intellisense on the document for my own code doesn’t work.

I can confirm same behavior on MacOS Mojave. I should probably create an issue on the ElixirLS plugin repo.

Thanks for your help!

1 Like


I’m currently still having this problem. Elixirls seems to only provide current module and Elixir autocompletion, but not for my projects other modules.

However, I can get it to work by disabling elixirls, and using vscode-elixir instead (but I then lose the goodness of elixirls).

On macOS Catalina. Any help would be great. I can make an issue if you’d like!

I do not use vscode anymore, and I am not sure who actually does.

Perhaps create an issue at and provide some logs from your LS output pane.

Especially what version of the LSP you are on, which version of the plugin you use and what versions of elixir are involved.

What are you using instead of vscode?

Emacs with lsp-mode and elixir-ls, as well as a plentora of others plugins.

Thanks @NobbZ. It would be nice to have a place where we can know what other options are available to write Elixir code. I tried many months ago to use IntelliJ but I failed to fully work on it. Then I switched to VsCode and so far so good.