How do I deploy project with Amnesia with `mix release` on production?

I have multiple disk schemas with Amnesia. But for some reason it doesn’t work when I deploy with mix release.

I have this in my Application module:

def start(_type, _args) do
    children = [

This is my CacheInitializer module.

defmodule MyApp.CacheInitializer do
  use Task, restart: :permanent

  @spec start_link(any()) :: :ignore | {:error, any()} | {:ok, pid()}
  def start_link(_init_args \\ []) do
    Task.start_link(__MODULE__, :run, [])

  def run() do
    if Application.get_env(:my_app, :app_config)[:env] == :prod do
end starts to write on the Amnesia tables. For dev, when I run with iex it works fine (also changing the if condition so it can work with dev). There I run command: mix amnesia.create -d Database --disk!.

The error I get when I run my release through start is:

15:14:52.447 [error] Task #PID<0.4991.0> started from MyApp.Supervisor terminating
** (stop) {:aborted, {:no_exists, Database.InValidRssCache}}
    (mnesia 4.18.1) mnesia.erl:361: :mnesia.abort/1
    (mnesia 4.18.1) mnesia_tm.erl:1067: :mnesia_tm.dirty/2
    (my_app 0.0.1) lib/my_app/amensia/database.ex:32: Database.InValidRssCache.write!/1
    (my_app 0.0.1) lib/my_app/invalid_rss_cache.ex:14: MyApp.InvalidRssCache.write!/2
    (elixir 1.13.4) lib/enum.ex:937: Enum."-each/2-lists^foreach/1-0-"/2
    (my_app 0.0.1) lib/my_app/cache_builder.ex:15:
    (elixir 1.13.4) lib/task/supervised.ex:89: Task.Supervised.invoke_mfa/2
    (stdlib 3.14) proc_lib.erl:226: :proc_lib.init_p_do_apply/3
Function: &
    Args: []
{"Kernel pid terminated",application_controller,"{application_terminated,my_app,shutdown}"}
Kernel pid terminated (application_controller) ({application_terminated,my_app,shutdown})

Crash dump is being written to: erl_crash.dump...done

I also start my release with $BOOT_SCRIPT_CLEAN, running Amnesia.start doesn’t help anything, as soon as I run my application, I get the same error.

Is there something else needs to be done here? Or is there a way I can run my application having Amnesia with mix release? Any help?