How to change default_locale in Gettext

gettext

#1

Hello,

I am supposed to create multi language website, therefore I am using gettext for this.
At first I created 3 language in my project and I made translations in it, but I couldn’t change default_locale like its document.

my project gited in https://github.com/shahryarjb/ESOGTIPH

for example I have 3 lang ["ru", "en", "fa"]

my router :

  pipeline :browser do
    plug :accepts, ["html"]
    plug :fetch_session
    plug :fetch_flash
    plug :protect_from_forgery
    plug :put_secure_browser_headers
    plug SetLocale, gettext: MultiLangWeb.Gettext, default_locale: "fa", cookie_key: "project_locale" #cookie_key is optional
  end

  pipeline :api do
    plug :accepts, ["json"]
  end

  scope "/", MultiLangWeb do
    pipe_through :browser # Use the default browser stack

    get "/", PageController, :dummy
  end

and my project config :

config :multi_lang, MultiLangWeb.Gettext,
    default_locale: "fa"

As you can see, I changed fa insted of en in my config , but it allways loads en default .

How can I changed default_locale to fa or ru?

I had read (https://phraseapp.com/blog/posts/i18n-for-phoenix-applications-with-gettext/),but there was no use for me .

please help me for changing it.

Thanks


#2

:default_locale is set in :gettext app config, I think.

https://hexdocs.pm/gettext/Gettext.html#module-default-locale


#3

Unfortunately, It does not work for me

I have tested this before

config :multi_lang, MultiLangWeb.Gettext,
    default_locale: "fa"

config :gettext, :default_locale, "fa"

or just

config :gettext, :default_locale, "fa"

my project gited in https://github.com/shahryarjb/ESOGTIPH


#4

Unfortunately, It does not work for me

Maybe you need to change the process’s locale and not the default locale for the app? Then you need to set it in one of your plugs probably.

https://hexdocs.pm/gettext/Gettext.html#put_locale/1

It will store locale info in the process dictionary and all subsequent operations in that process would have access to it.


#5

Hello ,

may you test my project in github because I can’t fix it? I think Gettext loads everything on config file and doesn’t show any reaction to put_locale/1 .

I have entered ‍Gettext.get_locale(MultiLangWeb.Gettext) in terminal and Gettext.put_locale(MultiLangWeb.Gettext, "fa"), after that I have tested ‍Gettext.get_locale(MultiLangWeb.Gettext) and it shows me fa, but I have a problem yet.

The en is still default page.

May I not know where I can enter the put_locale?


#6

Maybe in a plug somewhere before the controller action.

You seem to be doing it with https://github.com/shahryarjb/ESOGTIPH/blob/master/lib/multi_lang_web/router.ex#L12 already. Now you need to provide the appropriate accept-language headers in your request for it to work.


#7

Or not, I’m a bit confused at what https://github.com/smeevil/set_locale actually does.

Maybe try https://github.com/kipcole9/cldr with its plugs.

I personally find it easier to write these little plugs myself …


#8

Hi

Had the same problem here ; I found few things on Google and ended up with that. Default language will be used until the user sends a locale in params, then it will be stored in a simple cookie. Just use it in your plug and you should be fine.

I tried to make it work with get_req_header(conn, “accept-language”), but never found how to do nor why I should use that…

@locales Gettext.known_locales(MyappWeb.Gettext)

def call(conn, _opts) do
case locale_from_params(conn) || locale_from_cookies(conn) do
  nil ->
    Gettext.put_locale("mr") # Language by default no handled by Gettext
    conn
      |> persist_locale("mr")
  locale ->
    Gettext.put_locale(locale)
    conn
      |> persist_locale(locale)
   end
end

defp persist_locale(conn, new_locale) do
  conn |> put_resp_cookie("locale", new_locale, max_age: 10 * 24 * 60 * 60)
end
defp locale_from_params(conn) do
  conn.params["locale"] |> validate_locale
end
defp locale_from_cookies(conn) do
   conn.cookies["locale"] |> validate_locale
end
defp validate_locale(locale) when locale in @locales, do: locale
defp validate_locale(_locale), do: nil

#9

I followed this tutorial and it works for me: Phoenix I18n.
The difference I noticed at first glance between the way you’re setting default locale in config is that you don’t provide the full list of supported locales.
For example
config :demo, I18ndemoWeb.Gettext, default_locale: ru, locales: ~w(en ru)
I hope it will heelp…
That works for me.


#10

If you try the following, what do you see?

iex -S mix
iex> Gettext.known_locales MultiLangWeb.Gettext
iex> Gettext.default_locale MultiLangWeb.Gettext

The last function call should return fa in your configured case (you shouldn’t need to configure the :locales key).

If for some reason you aren’t seeing fa then I think there is a different problem.