How to extend the Pry/Debugger timeout in Phoenix (shell process exited with reason: shutdown)

When I use IEx.pry or a breakpoint (via :int.break()), the shell dies too quickly, and I only have ~10 seconds before I lose my session:

`** (EXIT from #PID<0.606.0>) shell process exited with reason: shutdown`

And 10 seconds isn’t enough to productively debug my code in the shell/debugger. My best guess is that there’s a default timeout in a :supervisor.child_spec that I need to override, but I’m not 100% sure.

This is what I’ve tried so far (and why they haven’t worked so far):

  • Increase the :timeout parameter to :infinity in the child_specs to Supervisor.start_link() in MyApp.Application.
  • Updated the cowboy idle_timeout because Observer indicated that my request is a cowboy process. I don’t think it’s likely that it’s cowboy, though. If the default is 60s, I’m not even getting close to 60s.
  • Instead of using IEx.pry, I tried using the debugger (via :ni.break)
  • Just noting that I can’t use mix test --trace, which sets the timout to :infinity – I’m trying to debug an Endpoint action (not a test)

How do people use the debugger/IEx.pry? Are people just not encountering the 10s timeout like I am? Or is there a common configuration that I’m not using?

My application.ex in case it helps:

defmodule MyApp.Application do
  use Application

  def start(_type, _args) do
    children = [
      {MyApp.Web.Endpoint, [timeout: :infinity]},
      {Phoenix.PubSub, [name: MyApp.PubSub, adapter: Phoenix.PubSub.PG2]},
      {MyApp.Middleware.Ets.AnEtsThing, [name: MyApp.Middleware.Ets.AnEtsThing, table_name: :my_app_config_2]},
    opts = [strategy: :one_for_one, name: MyApp.Supervisor]
    Supervisor.start_link(children, opts)

  def config_change(changed, _new, removed) do
    MyApp.Web.Endpoint.config_change(changed, removed)
1 Like

Just noting that I tried a few cowboy configs, to no avail:

# in dev.exs
config :my_app, MyApp.Web.Endpoint,
  http: [
    port: 4000,
    protocol_options: [
      request_timeout: 100_000_000,
      shutdown_timeout: 100_000_000,
      idle_timeout: 100_000_000,
      linger_timeout: 100_000_000,

Confirming in a console that the config loaded a different port

iex(4)> MyApp.Web.Endpoint.config(:http)
  port: 4001,
  protocol_options: [
    request_timeout: 100000000,
    shutdown_timeout: 100000000,
    idle_timeout: 100000000,
    linger_timeout: 100000000

Oh, just noticed a bug in my original post. I mentioned setting :timeout in the Supervisor ChildSpec, but actually I used the :shutdown option. (:timeout doesn’t exist)

Hah, I found the issue. I answered my own question in Stack Overflow: Why does the Pry shell timeout so quickly in Phoenix/cowboy? (shell process exited with reason: shutdown).

tl;dr. I had set a 10s timeout while working in a Javascript client, and then didn’t notice it shortened the Pry debugging session. Unsetting the timeout in development resolved the issue.

I ended up using Observer and traced the process to find the underlying Cowboy message 20:57:13:358740 (<0.5984.0>) exit {shutdown,{socket_error,closed,'The socket has been closed.'}}.