How to install on phoenix > 1.3?


I’m trying to install drab using the drab.install mix command. I got the following message:
** (Mix) Only Phoenix 1.3 is supported with the installer, please proceed with manual install.

The thing I’m wondering is if the manual install instructions from the github page work on phoenix 1.3.4 or if I’m better off downgrading to 1.3.

Thanks in advance.

It looks like a bug, it should work with all ~>1.3.0

Do you have your phoenix app under an umbrella? Which version of Drab do you use?

No umbrella, just a regular This is the dependencies list from mix.exs.

 defp deps do
  {:phoenix, "~> 1.3.4"},
  {:phoenix_pubsub, "~> 1.0"},
  {:phoenix_html, "~> 2.10"},
  {:phoenix_live_reload, "~> 1.0", only: :dev},
  {:gettext, "~> 0.11"},
  {:cowboy, "~> 1.0"},
  {:drab, "~> 0.9.1"}

Btw, should I open an issue on github if this turns out to be a bug?

Yes please!
I will try to reproduce it on my environment.

1 Like

This is weird, I’ve just checked and all works with 1.3.4 in my environment.

Could you please check:

`iex(2)> Application.spec(:phoenix, :vsn)

I’m getting nil.

1 Like

That’s really weird.
For a workaround, please try

mix deps.clean --all
mix deps.get
mix drab.install

I managed to reproduce the issue: it is happening when you compile deps before install. I have no idea why.

If it does not work, please do the manuall installation, the issue is with the installer only.

1 Like

I’ll add this to the issue.

1 Like

The workaround works :slight_smile:
Thank you.

Btw, here’s the issue on github.