How to make my rebar3 visible

Mix cannot see my rebar3 after trying to to "mix ecto.create"and gives me this error

** (Mix) Could not find “rebar3” to compile dependency :ranch, please ensure “rebar3” is available

I have my rebar3 installed and when i run ./rebar3 --version it gives me this version

rebar 3.14.1+build.4786.ref3b22d63f on Erlang/OTP 24 Erts 12.0.3

I have my paths set both in .bashrc and .profile pointing to the folder containing rebar3 although
i have another rebar (rebar 2,7) but i have removed theenvironment variable reffering to it to remove
conflicts.

Thanks! :smiley:

mix local.rebar3

I think it’s an internal rebar3…

1 Like

I need to clarify what you mean. If i run mix local.rebar3, will it install another rebar? and do i need to set the paths?

I just ran the command and it gave me this error below

** (Mix) The task “local.rebar3” could not be found. Did you mean “local.rebar”?
Note no mix.exs was found in the current directory

I think Phoenix uses it’s own rebar, not for external usage…

And yes, it should be mix local.rebar

1 Like

Its frustrating to fix error after error after error…now db issues again :frowning:

But thanks for your input. I highly appreciate

I always overwrite mix’s rebar3 with my install so there is no confusion.

derek@mail:~$ ls .mix/ -al
total 212
drwxr-xr-x  3 derek derek   4096 May  3 11:04 .
drwxr-xr-x 42 derek derek   4096 Oct 29 18:06 ..
drwxr-xr-x  4 derek derek   4096 Oct 27 18:14 archives
-rwxr-xr-x  1 derek derek 204449 Jun 11  2020 rebar
lrwxrwxrwx  1 derek derek     22 May  3 11:04 rebar3 -> /home/derek/bin/rebar3

1 Like