How to stop Supervisors starting GenServer during Exunit tests?

I’m having difficult figuring out how to stop supervisors running genservers during my tests and I haven’t found any helpful guides online.

I have the following setup in a test file:

setup do
  {:ok, server_pid} = Program.Myserver.start_link()
  {:ok, server: server_pid}

When I run my tests I get an
** (MatchError) no match of right hand side value: {:error, {:already_started, #PID<0.405.0>}}

No doubt because the supervisor has already started the genserver but I don’t know how to stop it doing this during my tests…

Any ideas on the best way to stop this?


You just need to tear it down after, see another thread already talking about this at:


1 Like

Since Elixir 1.5 the recommened approach for starting processes in a test is to use start_supervised/2. This is an easy way to ensure the process is started and stopped together with the test process.


I tried to do this:

setup do

But I get the below error…

1) test consume a payment message (CeresCore.Queue.Consumers.PaymentConsumerTest)
** (RuntimeError) expected ExUnit callback in 
CeresCore.Queue.Consumers.PaymentConsumerTest to return :ok | keyword | map, got {:error, {{:EXIT, {:undef, [{CeresCore.Queue.Consumers.PaymentConsumer, :start_link, [[]], []}, {:supervisor, :do_start_child, 2, [file: 'supervisor.erl', line: 365]}, {:supervisor, :handle_start_child, 2, [file: 'supervisor.erl', line: 724]}, {:supervisor, :handle_call, 3, [file: 'supervisor.erl', line: 422]}, {:gen_server, :try_handle_call, 4, [file: 'gen_server.erl', line: 636]}, {:gen_server, :handle_msg, 6, [file: 'gen_server.erl', line: 665]}, {:proc_lib, :init_p_do_apply, 3, [file: 'proc_lib.erl', line: 247]}]}}, {:child, :undefined, CeresCore.Queue.Consumers.PaymentConsumer, {CeresCore.Queue.Consumers.PaymentConsumer, :start_link, [[]]}, :permanent, 5000, :worker, [CeresCore.Queue.Consumers.PaymentConsumer]}}} instead
(ex_unit) lib/ex_unit/callbacks.ex:455: ExUnit.Callbacks.raise_merge_failed!/2

Is there like an example project where this is done with start_supervised?

I see lots of snippets of code but I can’t seem to get any of them working…and I don’t quite know what the error message wants me to fix…

The setup callback needs you to return one of those types. Like:

setup do

The other issue appears to be that CeresCore.Queue.Consumers.PaymentConsumer.start_link/1 is not a function that exists.

1 Like

I’ve changed my setup call back to what you specified and that fixed one error, so I’m one step closer…

and I made the start_link function as follows to define start_link/1

  def start_link(_ \\ nil) do
      GenServer.start_link(__MODULE__, [], name: __MODULE__)

However start_supervised still returns already_started error…

{{:already_started, #PID<0.407.0>},
{:child, :undefined, CeresCore.Queue.Consumers.PaymentConsumer,
{CeresCore.Queue.Consumers.PaymentConsumer, :start_link, [[]]}, :permanent,
5000, :worker, [CeresCore.Queue.Consumers.PaymentConsumer]}}}

What I typically do for this situation is set something like this in config/test.exs:

config :my_app, :env, :test

Then in my application supervisor, I separate out the processes I don’t want to start automatically and check the env.

children = [{MyApp.Endpoint, []), {MyApp.Repo, []}]

children = case Application.get_env(:my_app, :env) do
  :test -> children ++ [{MyApp.OtherThing, []}]
  _ -> children

Supervisor.init(children, strategy: :one_for_one)

If there’s a better way than this, I’m not aware of it.


Thats seems helpful but I’m still unable to just get the tests running sadly.
When I try to do it it just results in lower level supervisors not running…

The application itself works fine… but the tests won’t start.

Is there anywhere to find a full working example of using start_supervised?
So I can do a line by line comparison with my code.

All I find are snippets but they just aren’t working for me.

edit I was able to get get it sort of working now by conditionally loading genservers based on the environment. Seems clunky having to litter every single supervisor with an environment check, but I guess thats what has to be done.

Thanks for your help.

I think the OP’s problem is that they defined some GenServer to be started in application.ex, but wants to start the same server under the test setup block, therefore encountered the :already_started error. It’s not the same issue as the one in the link you provided.

1 Like

It seems that the easiest way to solve it is just to start your GenServer under a different name, using the :name option? Though if your GenServer functions depend on a hardcoded :name such as __MODULE__ it would indeed making testing harder.

e.g. instead of writing

  def start_link(_) do
    GenServer.start_link(__MODULE__, :ok, name: __MODULE__)


  def start_link(opts) do
    GenServer.start_link(__MODULE__, :ok, opts)

and then the child spec:

        id: MyApp.MyGenServer,
        start: {MyApp.MyGenserver, :start_link, [[name: MyApp.MyGenServer]]}

then in your test you can give a different name, e.g.

  setup context do
    _ = start_supervised!({MyApp.MyGenserver, name: context.test})
    %{producer: context.test}
1 Like