I installed elxir on a windows machine, but both elexir and mix commands are not found

I installed elixir for the first though the downloader on their website and then I ran the mix command but all I got was mix: command not found. I know elixir is installed. I checked both mix and elixir are installed on my machine . I tried reinstalling but that didn’t help much.

1 Like

IIRC I think you need to make sure the path to erlang and elxir bin is in your PATHs (and is correct).


May I suggest you try scoop installer?

scoop install erlang
scoop install elixir


The Commands are defined after a couple of reinstalls and installs, but now i get this . Any tips?
16:44:06.915 [error] beam\beam_load.c(86): Error loading module ‘Elixir.Code.Formatter’:
lambda already defined for label 749. To fix this, please recompile this module with an OTP 25 compiler.

16:44:06.915 [error] Loading of c:/Program Files (x86)/Elixir/bin/…/lib/elixir/ebin/Elixir.Code.Formatter.beam failed: :badfile

** (UndefinedFunctionError) function Code.Formatter.locals_without_parens/0 is undefined (module Code.Formatter is not available)
(elixir 1.13.4) Code.Formatter.locals_without_parens()
(elixir 1.13.4) lib/code/normalizer.ex:22: Code.Normalizer.normalize/2
(elixir 1.13.4) lib/code.ex:1107: Code.quoted_to_algebra/2

This may help:

Ah yes, sorry that broke with the recent OTP release. The elixir that comes from scoop isn’t compiled with the latest OTP.

You can get most combinations from GitHub - hexpm/bob: The Builder.

Extract this over the top of what’s in ~/scoop/apps/elixir/1.13.4/: https://repo.hex.pm/builds/elixir/v1.13.4-otp-25.zip. that will get you out of trouble for now.

1 Like