Idea for naming modules and functions

I have this idea on naming: using verbs for modules and nouns for functions.

For example:

Draw.board(), Deploy.system(), Format.result(), …

What do you guys think? Useful? Any possible disadvantages?

PS.: This is not a proposal or wanting to use every time. Just an idea to name some functions and some modules for readability…

It just looks the opposite to me.

nouns for module, verbs for action.

Board.draw(), System.deploy(), Result.format()

To me, a function is more an action than a thing :slight_smile: but who knows…

BTW How do You express clearing a board? Clear.board()? It seems wrong as soon as You have more than one function per module.