iex -S mix -S : could not find executable mix

New to learning Elixir and I am trying to troubleshoot a problem. I used and I am able to get deps and compile but whenever I try to use iex -S mix I get an error that I cant resolve. I tested this and used mix new example still the same effect.

I am on windows 10.

which mix
/c/Program Files (x86)/Elixir/bin/mix

mix --version
Erlang/OTP 21 [erts-10.0] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1]

Mix 1.7.4 (compiled with Erlang/OTP 19)

iex --version
IEx 1.7.4 (compiled with Erlang/OTP 19)

The following are on my System variable path.
C:\Program Files\erl10.0\bin
C:\Program Files (x86)\Elixir\bin
C:\Program Files (x86)\Elixir\bin\mix

Can you please post the full error message you get?

Also please tell us if you are using cygwin or another posix wrapper.

I am executing this command in the root directory.

iex -S mix
-S : Could not find executable mix

I am not using any posix wrapper. Only using cmder and atom.

Information mismatch.

which is not available in cmd nor powershell, also the path given (/c/Program Files (x86)/Elixir/bin/mix) is clearly hinting that you are using some kind of POSIX wrapper which gives you linux like environment in windows.

Do you have the same problem when you use cmd directly?

1 Like

I don’t know which POSIX wrapper I am using within cmder but I get the same error when I run the command using cmd directly.