Installing Elixir on Ubuntu 15.10

If I try to install on Ubuntu 15.10 I get the error message below.

Any ideas?

The following packages have unmet dependencies:
 esl-erlang : Depends: libssl0.9.8 but it is not installable
              Recommends: erlang-mode but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
1 Like

Have you tried installing libssl-dev first?

I’m not that familiar with Ubuntu but I guess with something like:

sudo apt-get install libssl-dev
1 Like

First as I remember Ubuntu had outdated Erlang.
To install the latest erlang

Second you don’t need to install Elxiir. You can download binary files and add location to your path.

This is how you can have the latest setup.

Now I am running :slight_smile:



I started from scratch and installed from the repository as described on

sudo dpkg -i erlang-solutions_1.0_all.deb
sudo apt-get update
sudo apt-get install esl-erlang
sudo apt-get install elixir

This gives me the following versions:

root@simon:~# iex
Erlang/OTP 18 [erts-7.3] [source-d2a6d81] [64-bit] [smp:4:4] [async-threads:10] [hipe] [kernel-poll:false]

Interactive Elixir (1.2.3) - press Ctrl+C to exit (type h() ENTER for help)

I will have a look at the Elixir binary files if I need a newer version. Thanks.

And I will give KDE neon a try as well. Looking good.

Just installed KDE neon. Looks refreshing, clean, easy to use.:smiley:

1 Like

Off topic:
If you want cool console for kde try Yakuake

If you want cool shell try Oh My Fish

And you will never back to windows OS again :smiley:


I think you’re better to use kiex and kerl to manage the Elixir / Erlang version.

Since quite a number of libraries are depending the newer version Elixir


This actually worked for me:
To fix the error with esl-erlang

echo 'deb xenial contrib' | sudo tee -a /etc/apt/sources.list


sudo apt-key add erlang_solutions.asc

sudo apt update && sudo apt install esl-erlang

And then I could install elixir:

sudo apt-get install elixir