Intellij-elixir phoenix debugger error

I’m trying to setup intellij to give it a try but I’m having trouble getting it working with Phoenix.
I have created a new Run/Debug configuration, set my program arguments to phx.server. When I run the project using the debug button it appears to run but when I visit the page I’m greeted with the error Internal server error. The console in intellij shows this:

[info] Running WebsiteWeb.Endpoint with Cowboy using
23:22:31 - info: compiled 6 files into 2 files, copied 3 in 587 ms
[info] GET /
[debug] Processing with WebsiteWeb.PageController.index/2
  Parameters: %{}
  Pipelines: [:browser]
[info] Sent 200 in 46ms
[info] Sent 500 in 66ms
[error] #PID<0.549.0> running WebsiteWeb.Endpoint terminated
Server: (http)
Request: GET /
** (exit) {%ArgumentError{message: "argument error"}, []}

Oddly enough when I run the project using the same configuration by clicking the “run” button in intellij it works perfectly fine.

Is there something I’m missing or have misconfigured? I’d like to be able to set break points and use the debugger.

You can’t do this in any available IDE, also there is not much effort put into this as step-by-step-debugging has a lot of drawbacks in the concurrent world.

There are tools available in the erlang eco-system that do allow to do step-by-step debugging, but I never used them with elixir. Also I only tried once or twice with erlang, I realized nearly instantly that I am not able to analyze where, what and why I am doing during the timeouts of dependent processes and so during debugging the main reason for failure was simply me not beeing able to debug in nanoseconds…

@Ripster I’m seeing the same behavior in IntelliJ CE and Rubymine when debugging a Phoenix app. However it works fine when just a regular Elixir app. The endpoint is terminating as soon as the browser makes a request. Suggest you post an issue on the plugin’s GitHub page. @KronicDeth is usually pretty quick to respond. I could be that this just isn’t supported as @NobbZ said, or could just be a bug in the plugin.

Thanks. I will try the GitHub page. The reason I expected it to work is that the GitHub page explicitly mentions Phoenix as well as breakpoints and stepping. There are even screenshot examples of setting breakpoints in Intellij so I do expect there is a bug or something wrong with my setup.

Given no other information and since the logger doesn’t show the error, I’m going to guess it is this bug, which was actually a bug with Logger, which turned out to be a bug with :dbg_ieval, which is part of the debugger in OTP. @josevalim fixed the :dbg_ieval bug, but that means you need to wait until the next version of OTP to be released to get the fix (or erlc just that module to get the fix).

You can work around the problem for now by excluding modules from being interpreted that trigger the bug. In most cases this will be modules that have Logger calls that take an anonymous function and then interpolate inside that anonymous function like

thing = ... -> "thing=#{thing}" end)

Excluding WebsiteWeb.Endpoint seems to have fixed it. I don’t have any explicit calls to the logger but it does use Phoenix.Endpoint and have calls to plug, both of which I believe have Logger calls with interpolated anonymous functions in them.

Thank you very much for taking time to explain the issue and help get it fixed!