Intellij fails to create Terminal Session

Hi guys,

I am new to Intellij and have the following error:

Error running ‘run_in_iex’: com.intellij.terminal.JBTerminalWidget.createTerminalSession(Lcom/jediterm/terminal/TtyConnector;)Lcom/jediterm/terminal/ui/TerminalSession;

I am currently using OpenSuse Leap 15
IntelliJ IDEA 2018.3 (Community Edition)
Build #IC-183.4284.148, built on November 21, 2018
JRE: 1.8.0_152-release-1343-b15 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.12.14-lp150.12.25-default

The application does start but the error show up and unable to access the terminal (ALT+4) window.

@KronicDeth, Any help and suggestions are welcome.

Thanks

I’m having the same issue.

Do you have a longer stack trace? That one line isn’t a lot to go on. That format with the L in the class name is usually something the class loader or reflection API in Java spits out, so it could be that in 2018.3 changed the bundled version of Jedi, which is the cross-platform terminal emulator library. It must be a change in 2018.3 that was released because I hadn’t seen the issue with the EAP.

In the future, you can open bug reports like this as issues in the GitHub repo.

Thanks,

My “Event Log” is showing only this lines:

11/25/18
12:18 PM	Compilation completed successfully in 2 s 780 ms

12:18 PM	Error running 'run_in_iex': com.intellij.terminal.JBTerminalWidget.createTerminalSession(Lcom/jediterm/terminal/TtyConnector;)Lcom/jediterm/terminal/ui/TerminalSession;

Can I enable a more detail log? I have been searching for it but unable to find it.

I will file a bug report.

Thanks

Darn! I’m stuck on this too.

I opened up this issue in GitHub:

https://github.com/KronicDeth/intellij-elixir/issues/1352

I went back to Vim.

Best regards

1 Like

Great, thanks for doing that. As for vim, I love the speed and the keys, but now that I’ve given IDEA a chance, I’m super happy with it. I’m able to use Python, Elixir, PostgreSQL, and Clojure all at the same time!

Only the iex -S isn’t working because of this issue, but it’s a small thing to wait for; after all, I wasn’t doing iex in vim either!

For anyone following this thread: the issue has been fixed in https://github.com/KronicDeth/intellij-elixir/pull/1368 and the fix is released in version 10.2.0 of the plugin that I just released.

1 Like

Thanks for your help