Intellisense in VSCode not working

Why my intellisense doesn’t work? Pressing ctrl + space doesn’t work either.

I couldn’t find the reason why isn’t working.

Extension version: 0.19.0
Erlang/OTP 26 [erts-14.0.2] [source] [64-bit] [smp:12:12] [ds:12:12:10] [async-threads:1] [jit:ns]

Elixir 1.15.4 (compiled with Erlang/OTP 26)
Windows 10

The output doesn’t show any problem. Here’s the output:


"[elixir]": {
    "editor.insertSpaces": true,
    "editor.tabSize": 2,
    "editor.wordBasedSuggestions": "allDocuments",
    "editor.formatOnType": true,
    "editor.trimAutoWhitespace": false,
    "editor.snippetSuggestions": "bottom",
    "files.trimTrailingWhitespace": true,
    "files.insertFinalNewline": true,
    "files.trimFinalNewlines": true

Any ideas?

What extension are you using? Intellisense is provided by ElixirLS, Lexical or elixir-tools.

I’m using ElixirLS, I tried to use elixir-tools but I didn’t have success too.

Do you see a .elixir_ls in the root of the project? Or any additional output when you try saving the file?

Please update to a supported OTP >= 26.2 version or downgrade to 25. On windows OTP versions 26.0 and 26.1 are broken


Upgrading Erlang to v26.2 solved the problem.


This happened to me before also, also updating the versions fixed it :slight_smile: