Issue when deploying with gigalixir

When I try to deploy with gigalixir I get this error. I don’t know why it’s so difficult to deploy elixir…

-----> Checking Erlang and Elixir versions
       Will use the following versions:
       * Stack cedar-14
       * Erlang 21.0
remote:  Elixir 1.9.1
-----> Using cached Erlang 21.0
-----> Installing Erlang 21.0

remote:  for generic OTP version
remote: Command '[u'docker', u'run', u'--memory-reservation=512m', u'--rm', u'-e', 
u'GIGALIXIR_SHOULD_CLEAN_CACHE=False', u'-v', u'/tmp/tmppIn5TT/sizzling-embarrassed-hound:/tmp/app', u'-v', 
u'/tmp/gigalixir/cache/sizzling-embarrassed-hound/:/tmp/cache', u'-v', 
u'/tmp/tmppIn5TT/env:/tmp/env', u'--env=USER=www-data', u'']' 
returned non-zero exit status 1
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to ''

Any idea…? Thanks

The Erlang, Elixir versions have to be the same on the server you are deploying and on your local machine

I’ve just done it but it still doesn’t work…

Also have you read this guide

Hi. I haven’t tried deploying with Gigalixir, so I’m not sure if I can be much help. The error message is very vague. Is this the first time you deploy the application?

I’d suggest opening an issue on on their repo if you can’t make progress with it. Maybe suggest they work on improving the error message :slight_smile:

My guess is you’re running into this error here

Which suggests that the buildpack can’t find the elixir version for some reason. What version of elixir do you have set in your elixir_buildpack.config? Make sure it’s a supported version. See