Kafka_ex :unsupported_version

On our staging server we have Kafka 2.8.1 installed. Running our app with kafka_ex 0.13 gives a :unsupported_version error: (our app is called dockr, not a typo )

 | 10:00:39.308 [error] GenServer #PID<0.1259.0> terminating
app_1  | ** (CaseClauseError) no case clause matching: :unsupported_version
app_1  |     (kafka_ex 0.13.0) lib/kafka_ex/gen_consumer.ex:929: KafkaEx.GenConsumer.load_offsets/1
app_1  |     (kafka_ex 0.13.0) lib/kafka_ex/gen_consumer.ex:660: KafkaEx.GenConsumer.handle_info/2
app_1  |     (stdlib 4.2) gen_server.erl:1123: :gen_server.try_dispatch/4
app_1  |     (stdlib 4.2) gen_server.erl:1200: :gen_server.handle_msg/6
app_1  |     (stdlib 4.2) proc_lib.erl:240: :proc_lib.init_p_do_apply/3
app_1  | Last message: :timeout
app_1  | State: %KafkaEx.GenConsumer.State{consumer_module: Dockr.Kafka.Consumer, consumer_state: nil, commit_interval: 1000, commit_threshold: 100, worker_name: #PID<0.1260.0>, group: "dockr-cg", topic: "dockr", partition: 1, member_id: "kafka_ex-8066c9fb-9d7b-40e9-8159-91e06eec48d0", generation_id: 17, current_offset: nil, committed_offset: nil, acked_offset: nil, last_commit: nil, auto_offset_reset: :earliest, fetch_options: [auto_commit: false, worker_name: #PID<0.1260.0>], api_versions: %{fetch: 0, offset_commit: 0, offset_fetch: 0}}

I have tried to reproduce the issue locally; I can not find a kafka docker container or an install that has 2.8.1;
I tried it wih with all kinds of versions of cp-confluent (6.2.x), also installed kafka 2.8.2 from apache, but it all works well locally.

Anyone recognizes this what could be the issue?

Many thx in advance.

For anyone who faces the same issue: the reason for this was that the Kafka that was installed was Confluent Kafka, which apparently uses a different protocol which caused the issue.

I would have liked that the error was a bit more verbose than :unsupported_version.