Livebook environment reset on MacOS

I’ve been using livebook since before 0.10 and I have managed to get something in my settings that’s breaking all new livebook updates. I’ve tried resetting my environment by moving the directory in ~/Library/Application Support/livebook but it’s still crashing when I start a new livebook.

Is there another location for local settings I need to consider? I don’t mind a full reset.

I don’t know if it matters, but I’m using a homebrew cask to stay up to date.

Thanks for any help you can provide. Eventually I’ll have a nice open source DB related announcement using livebooks, but development has stopped until I can get this fixed.

How did you install Livebook?

1 Like

I have two. One is just from source, my favorite way to run it is from homebrew cask. Neither work at the moment, which is why I’m focused on settings directories. It’s slow but I can start a new notebook. However, when I run setup I get this:

Failed to connect to runtime - Elixir terminated unexpectedly, please check your logs for errors

I forgot to mention both are the latest from their respective sources.

From source:

Homebrew cask:

I installed Livebook from the .dmg file. The only livebook related files I can find on my system are in the user library application support folder, the application itself in the applications folder, a few .vim files in the usr/share/vim/vim90 subfolders, and a livebook_runtime which lives in what looks like a random named temp folder under private/var/folders/ss.

If you have killed all of the corresponding folders for you install and still have the problem then there must be some other piece hidden somewhere.

Have you tried starting from scratch with the dmg version?

1 Like

Thank you very much for your response. I’ve tried killing the application support folder and reinstalling from dmg multiple times. If anyone else has suggestions let me know.

My next steps are to figure out how to enable logging to see the exact errors.
Open JS debug console and see if I can see the request/response.

I’ll update if I’m able to isolate the issue in case others have similar issues.

Hey @awksedgreep1 :wave:

Do you have any custom script in your user folder? Livebook loads it on start GitHub - livebook-dev/livebook: Automate code & data workflows with interactive Elixir notebooks

Then, when starting Livebook Desktop you should be able to see the logs by clicking on the navbar icon → “View Logs” option. Did you try?

Good luck :crossed_fingers:

1 Like

I did. It’s not logging anything beyond startup. I was going to try and increase logging level and watch js console to see what’s going on. Could just be my vpn/firewall is blocking web sockets somehow.

There’s Library/Application Support/livebook/livebook_config.ets with config, but if that was the problem, Livebook itself would likely crash.

From the error it seems that when we start the notebook runtime elixir node it quickly crashes. Is there any error in Library/Logs/Livebook.log (or when running from source, in the terminal when you started livebook)?